summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/xgammon/files/gcc33.patch4
-rw-r--r--games-board/xgammon/files/xgammon-0.98-broken.patch2
-rw-r--r--games-board/xgammon/files/xgammon-0.98-config.patch4
-rw-r--r--games-board/xgammon/xgammon-0.98-r1.ebuild45
4 files changed, 50 insertions, 5 deletions
diff --git a/games-board/xgammon/files/gcc33.patch b/games-board/xgammon/files/gcc33.patch
index 90b001f2a196..82dcadd990c7 100644
--- a/games-board/xgammon/files/gcc33.patch
+++ b/games-board/xgammon/files/gcc33.patch
@@ -1,5 +1,5 @@
---- xgammon.c.orig 2004-05-07 14:44:07.000000000 -0700
-+++ xgammon.c 2004-05-07 14:45:52.000000000 -0700
+--- a/xgammon.c 2004-05-07 14:44:07.000000000 -0700
++++ b/xgammon.c 2004-05-07 14:45:52.000000000 -0700
@@ -944,31 +944,31 @@
for (option=1; option<argc; option++) {
if (strcmp (argv[option], "-?") == 0 ||
diff --git a/games-board/xgammon/files/xgammon-0.98-broken.patch b/games-board/xgammon/files/xgammon-0.98-broken.patch
index e02ac10b4992..e94afa0792a1 100644
--- a/games-board/xgammon/files/xgammon-0.98-broken.patch
+++ b/games-board/xgammon/files/xgammon-0.98-broken.patch
@@ -1,4 +1,4 @@
---- xgammon/lib/db.c.orig Sat Jan 6 12:14:12 2001
+--- xgammon/lib/db.c Sat Jan 6 12:14:12 2001
+++ xgammon/lib/db.c Sat Jan 6 12:13:56 2001
@@ -259,10 +259,11 @@
close(fid);
diff --git a/games-board/xgammon/files/xgammon-0.98-config.patch b/games-board/xgammon/files/xgammon-0.98-config.patch
index 363d1730933c..1cedd03de3dd 100644
--- a/games-board/xgammon/files/xgammon-0.98-config.patch
+++ b/games-board/xgammon/files/xgammon-0.98-config.patch
@@ -1,4 +1,4 @@
---- xgammon-0.98/xgammon.ad.rhconfig Tue Aug 29 01:35:39 1995
+--- xgammon-0.98/xgammon.ad Tue Aug 29 01:35:39 1995
+++ xgammon-0.98/xgammon.ad Wed Aug 12 18:22:25 1998
@@ -67,4 +67,4 @@
xgammon.buttonmove: false
@@ -6,7 +6,7 @@
xgammon.delaytime: 5
-xgammon.database: lib/xgammon.db
+xgammon.database: /usr/lib/X11/xgammon/xgammon.db
---- xgammon-0.98/Imakefile.rhconfig Wed Aug 23 15:26:39 1995
+--- xgammon-0.98/Imakefile Wed Aug 23 15:26:39 1995
+++ xgammon-0.98/Imakefile Wed Aug 12 18:42:55 1998
@@ -12,9 +12,9 @@
diff --git a/games-board/xgammon/xgammon-0.98-r1.ebuild b/games-board/xgammon/xgammon-0.98-r1.ebuild
new file mode 100644
index 000000000000..1c2aeed33cbd
--- /dev/null
+++ b/games-board/xgammon/xgammon-0.98-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs eutils
+
+DESCRIPTION="very nice backgammon game for X"
+HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
+SRC_URI="http://fawn.unibw-hamburg.de/steuer/xgammon/Downloads/${P}a.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake"
+
+S=${WORKDIR}/${P}a
+
+PATCHES=(
+ "${FILESDIR}/${P}-broken.patch"
+ "${FILESDIR}/${P}-config.patch"
+ "${FILESDIR}/gcc33.patch"
+)
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ env PATH=".:${PATH}" emake \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CC=$(tc-getCC)
+}
+
+pkg_postinst() {
+ einfo "xgammon need helvetica fonts"
+ einfo "They can be loaded emerging media-fonts/font-adobe-100dpi"
+ einfo "or similar. Remember to restart X after loading fonts"
+}