summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
index bf208b193813..acaec4e5c644 100644
--- a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
@@ -31,8 +31,10 @@ DEPEND="${DEPEND}
dev-python/pbr[${PYTHON_USEDEP}]"
# Keep just in case
-src_prepare() {
+python_prepare_all() {
sed -e 's:-o shwordsplit::' -i tests/run_tests || die
+
+ distutils-r1_python_prepare_all
}
python_test() {