summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/unittest2/unittest2-1.1.0.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/unittest2/unittest2-1.1.0.ebuild b/dev-python/unittest2/unittest2-1.1.0.ebuild
index 00602d11bc09..20c30f45d032 100644
--- a/dev-python/unittest2/unittest2-1.1.0.ebuild
+++ b/dev-python/unittest2/unittest2-1.1.0.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
inherit distutils-r1
@@ -25,13 +26,7 @@ CDEPEND="
DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}"
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/remove-argparse-dependence.patch
- )
-
- distutils-r1_python_prepare_all
-}
+PATCHES=( "${FILESDIR}"/remove-argparse-dependence.patch )
python_test() {
"${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"