summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xdo/Manifest1
-rw-r--r--x11-misc/xdo/xdo-0.5.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/xdo/Manifest b/x11-misc/xdo/Manifest
index d343cb8f406b..420526fd596b 100644
--- a/x11-misc/xdo/Manifest
+++ b/x11-misc/xdo/Manifest
@@ -1 +1,2 @@
+DIST xdo-0.5.6.tar.gz 7191 SHA256 cd2c1a672a02f288cfc08a05a0aadc716a170e27332d9db9d39d1ab7717f3a18 SHA512 0366f1eb473db32909619b9d7059e6528b071d920a3148c6f31b8911fc0cc5e0c9f8de56d95a0dfce29d554c76cdf967438d99c267826416bb03487efb78346d WHIRLPOOL f41ee47df8b26069d34a0f1776664f066f97a268b121f1c276c40535778c060209b8248352502a522afb6b432771fc8bede2186e4d7aebb603a7c4a8d05d29cc
DIST xdo-0.5.tar.gz 6853 SHA256 2686cfbe3727586fae770a033731a92abd35146951961a5e0bf781288296566a SHA512 a33a1480d45b641e471a65b93ac6d5b8c1922559370590a49dd27f5ff139ad59484e4c82266f1a0c2e2c8d6d237a56fc7122424d1270f34f7b9ba616fd04e486 WHIRLPOOL d239fda4bc970c04aa03e0815d598a451b633d023a6277a6c1b330d18246ea36899c1e4c1095de3e8a0fc79a67771a674992331028c154347c7edae5ed1e3024
diff --git a/x11-misc/xdo/xdo-0.5.6.ebuild b/x11-misc/xdo/xdo-0.5.6.ebuild
new file mode 100644
index 000000000000..785b54546acb
--- /dev/null
+++ b/x11-misc/xdo/xdo-0.5.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Small X utility to perform elementary actions on windows"
+HOMEPAGE="https://github.com/baskerville/xdo/"
+SRC_URI="https://github.com/baskerville/xdo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}