summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.10.4-drop-icon-theme-dep.patch33
-rw-r--r--mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild (renamed from mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild)16
2 files changed, 46 insertions, 3 deletions
diff --git a/mate-base/mate-applets/files/mate-applets-1.10.4-drop-icon-theme-dep.patch b/mate-base/mate-applets/files/mate-applets-1.10.4-drop-icon-theme-dep.patch
new file mode 100644
index 000000000000..41370299b511
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.10.4-drop-icon-theme-dep.patch
@@ -0,0 +1,33 @@
+From 0a9439346e00aded616fe99773ffec2f3f7bcc49 Mon Sep 17 00:00:00 2001
+From: raveit65 <chat-to-me@raveit.de>
+Date: Thu, 1 Oct 2015 00:27:53 +0200
+Subject: [PATCH] drop dpendency to mate-icon-theme
+
+The dependency is not really needed; depending on GTK+ should be enough
+to guarantee the presence of a spec-compliant icon theme.
+---
+ configure.ac | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b69e1a4..284dba7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,7 +20,6 @@ LIBNOTIFY_REQUIRED=0.7.0
+ UPOWER_REQUIRED=0.9.4
+ DBUS_REQUIRED=1.1.2
+ DBUS_GLIB_REQUIRED=0.74
+-MATE_ICON_THEME_REQUIRED=1.1.0
+ LIBXML_REQUIRED=2.5.0
+ POLKIT_REQUIRED=0.92
+ dnl ***************************************************************************
+@@ -122,9 +121,6 @@ dnl ***************************************************************************
+ dnl *** Use pkg-config to check for dependancies ***
+ dnl ***************************************************************************
+
+-dnl -- Check for mate-icon-theme (required) ----------------------------------
+-PKG_CHECK_MODULES(GIT, mate-icon-theme >= $MATE_ICON_THEME_REQUIRED)
+-
+ dnl -- check for gio (required) ------------------------------------------
+ PKG_CHECK_MODULES(GIO, gio-2.0 >= $GIO_REQUIRED gio-unix-2.0)
+ AC_SUBST(GIO_CFLAGS)
diff --git a/mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild b/mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild
index ebfebd09b6c8..fdde0c29dc37 100644
--- a/mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild
@@ -7,7 +7,7 @@ EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python2_7 )
-inherit eutils gnome2 python-single-r1 versionator
+inherit eutils gnome2 python-single-r1 autotools versionator
MATE_BRANCH="$(get_version_component_range 1-2)"
@@ -17,7 +17,7 @@ HOMEPAGE="http://mate-desktop.org"
LICENSE="GPL-2 FDL-1.1 LGPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="X ipv6 policykit +upower"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -45,7 +45,6 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/libX11:0
>=x11-libs/libwnck-2.30:1
x11-libs/pango:0
- >=x11-themes/mate-icon-theme-1.10:0
virtual/libintl:0
policykit? ( >=sys-auth/polkit-0.92:0 )"
@@ -59,6 +58,17 @@ DEPEND="${RDEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.10.4-cpupower-4.7.patch"
+ "${FILESDIR}/${PN}-1.10.4-drop-icon-theme-dep.patch"
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+ eautoreconf
+ gnome2_src_prepare
+}
+
src_configure() {
gnome2_src_configure \
--libexecdir=/usr/libexec/mate-applets \