summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/bpftrace/bpftrace-0.9-r1.ebuild8
-rw-r--r--dev-util/bpftrace/bpftrace-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/bpftrace/bpftrace-0.9-r1.ebuild b/dev-util/bpftrace/bpftrace-0.9-r1.ebuild
index 393a086df3b7..68c9292ad9c0 100644
--- a/dev-util/bpftrace/bpftrace-0.9-r1.ebuild
+++ b/dev-util/bpftrace/bpftrace-0.9-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs cmake-utils
+inherit toolchain-funcs linux-info cmake-utils
DESCRIPTION="High-level tracing language for eBPF"
HOMEPAGE="https://github.com/iovisor/bpftrace"
@@ -45,6 +45,12 @@ PATCHES=(
# lots of fixing needed
RESTRICT="test"
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~BPF_JIT ~EBPF_JIT BPF_EVENTS"
+
+ check_extra_config
+}
+
src_prepare() {
cmake-utils_src_prepare
}
diff --git a/dev-util/bpftrace/bpftrace-9999.ebuild b/dev-util/bpftrace/bpftrace-9999.ebuild
index 393a086df3b7..68c9292ad9c0 100644
--- a/dev-util/bpftrace/bpftrace-9999.ebuild
+++ b/dev-util/bpftrace/bpftrace-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs cmake-utils
+inherit toolchain-funcs linux-info cmake-utils
DESCRIPTION="High-level tracing language for eBPF"
HOMEPAGE="https://github.com/iovisor/bpftrace"
@@ -45,6 +45,12 @@ PATCHES=(
# lots of fixing needed
RESTRICT="test"
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~BPF_JIT ~EBPF_JIT BPF_EVENTS"
+
+ check_extra_config
+}
+
src_prepare() {
cmake-utils_src_prepare
}