summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/catch/catch-1.5.6.ebuild17
-rw-r--r--dev-cpp/catch/catch-9999.ebuild17
2 files changed, 14 insertions, 20 deletions
diff --git a/dev-cpp/catch/catch-1.5.6.ebuild b/dev-cpp/catch/catch-1.5.6.ebuild
index 7034812e69c1..15572fe776f0 100644
--- a/dev-cpp/catch/catch-1.5.6.ebuild
+++ b/dev-cpp/catch/catch-1.5.6.ebuild
@@ -13,22 +13,19 @@ SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE=""
S=${WORKDIR}/${P^}
CMAKE_USE_DIR=${S}/projects/CMake
-src_configure() {
- # CMake is only used to build & run tests
- use test && cmake-utils_src_configure
-}
-
-src_compile() {
- use test && cmake-utils_src_compile
-}
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
src_test() {
- use test && cmake-utils_src_test
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
}
src_install() {
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index ee8fefd8da7c..8fb27fb7cc50 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -14,21 +14,18 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE=""
CMAKE_USE_DIR=${S}/projects/CMake
-src_configure() {
- # CMake is only used to build & run tests
- use test && cmake-utils_src_configure
-}
-
-src_compile() {
- use test && cmake-utils_src_compile
-}
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
src_test() {
- use test && cmake-utils_src_test
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
}
src_install() {