summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rdoc/Manifest1
-rw-r--r--dev-ruby/rdoc/rdoc-4.3.0.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/dev-ruby/rdoc/Manifest b/dev-ruby/rdoc/Manifest
index 4496c70911f8..922715cd2bfe 100644
--- a/dev-ruby/rdoc/Manifest
+++ b/dev-ruby/rdoc/Manifest
@@ -1,4 +1,3 @@
-DIST rdoc-4.3.0.gem 738816 BLAKE2B f705b4fed5a9a7e3a850cacc17b7df3f8fdeb163938ed7d2d29979337cb24bca4a66695643ecc62f811d8e49a931296e1972d5d13366685315649e0ec44ebef7 SHA512 7ec5c8055262300c159ff2dbca3bcd09e169002acad8602db89086d2b9409a096209a1152dca68c79dcd1b5e3c1fdf55e7f89d82b33fa2ce65c816695350b029
DIST rdoc-5.1.0.tar.gz 702376 BLAKE2B 733d77a341ddad10f5b648b6bb492e0f79daa392e2ca371d38236e4c85a1c409699e35dd3f5bc8bc48551b399603bb0a747cb3c5f7f1fbf4765aabffaad575aa SHA512 cd2ed37e8502a3e9093c88c258ac5e39542a23c3dcaedb9b5eb48ce391a694e5b35fbcfd62f01ec6353ac9c40a4b7043b2ff11bbc403d2e03de9a84c52bcefe7
DIST rdoc-6.0.4.tar.gz 699314 BLAKE2B 37b9c65a55357b9edbf85889c086948a6e80094846434d46e6ffbf17e16eba9e964dc09721f921d5042d6e0c72619fc59d87c8d969490e6af50fddaf49d36556 SHA512 8bf61bda88ea1a85178f5fdd62e87c79c5efd6d6f64d9d8651bbbc37e02da02b7189c7e60e4853a962507cc2ee4c703b6532f28db763202fa24c4b364cee8e28
DIST rdoc-6.1.0.tar.gz 701204 BLAKE2B 5228f7af6b890aa09ddeee899955dada94768a4a4fe6c30ccfabb810dc90420f5a83e1a485b80ddfa81c6eeca9440109a82a3287eb445c28e1c4f30b3cea76bf SHA512 084c6bf8819664ab5f80d3678dbc8936da30f19f8603767d3678b7d504069395c8e074d09b4a188231784fb99213ee0cb2e289632de4126276ddb0233fbcd600
diff --git a/dev-ruby/rdoc/rdoc-4.3.0.ebuild b/dev-ruby/rdoc/rdoc-4.3.0.ebuild
deleted file mode 100644
index 88259c168764..000000000000
--- a/dev-ruby/rdoc/rdoc-4.3.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
-HOMEPAGE="https://github.com/rdoc/rdoc/"
-
-LICENSE="Ruby MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- dev-ruby/racc
- test? (
- >=dev-ruby/minitest-5.8:5
- )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4:0"
-
-all_ruby_prepare() {
- # Other packages also have use for a nonexistent directory, bug 321059
- sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/test_rdoc*.rb || die
-
- # Remove unavailable and unneeded isolate plugin for Hoe
- sed -i -e '/isolate/d' Rakefile || die
-
- # Remove licenses line from Hoe definitions so we also use older versions.
- sed -i -e '/licenses/ s:^:#:' Rakefile || die
-
- epatch "${FILESDIR}/${PN}-3.0.1-bin-require.patch"
-
- # Remove test that is depending on the locale, which we can't garantuee.
- sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
-
- # Remove test depending on FEATURES=userpriv, bug 361959
- sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
-
- # Remove tests for code that is not included and not listed in Manifest.txt
- rm -f test/test_rdoc_i18n_{locale,text}.rb \
- test/test_rdoc_generator_pot* || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- ruby -Ilib -S bin/rdoc || die
- fi
-}
-
-each_ruby_compile() {
- # Generate the file inline here since the Rakefile confuses jruby
- # into a circular dependency.
- for file in lib/rdoc/rd/block_parser lib/rdoc/rd/inline_parser ; do
- ${RUBY} -S racc -l -o ${file}.rb ${file}.ry || die
- done
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e 'gem "json", "~>1.4"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for bin in rdoc ri; do
- ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
-
- for version in 23; do
- if use ruby_targets_ruby${version}; then
- ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
- sed -i -e "1s/env ruby/ruby${version}/" \
- "${ED}/usr/bin/${bin}${version}" || die
- fi
- done
- done
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/rdoc) ]] ; then
- eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
- fi
-}