summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/attic/Manifest1
-rw-r--r--app-backup/attic/attic-0.16.ebuild33
-rw-r--r--app-backup/attic/attic-9999.ebuild33
-rw-r--r--app-backup/attic/metadata.xml8
-rw-r--r--app-emulation/xen/xen-4.5.2-r2.ebuild5
-rw-r--r--app-emulation/xen/xen-4.5.2-r3.ebuild4
-rw-r--r--app-emulation/xen/xen-4.6.0-r3.ebuild4
-rw-r--r--app-emulation/xen/xen-4.6.0-r4.ebuild4
-rw-r--r--dev-perl/AnyEvent/AnyEvent-7.80.0.ebuild2
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-0.9.14.ebuild65
-rw-r--r--dev-python/carbon/files/carbon-0.9.14-no-data-files.patch32
-rw-r--r--dev-python/whisper/Manifest1
-rw-r--r--dev-python/whisper/whisper-0.9.15.ebuild18
-rw-r--r--net-analyzer/wireshark/wireshark-2.0.0-r1.ebuild1
-rw-r--r--net-analyzer/wireshark/wireshark-2.0.0.ebuild1
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0-r1.ebuild58
-rw-r--r--net-dns/dnscrypt-proxy/files/dnscrypt-proxy.confd-1.6.0-r113
-rw-r--r--net-dns/dnscrypt-proxy/files/dnscrypt-proxy.initd-1.6.0-r160
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.4-cmake.patch70
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.4-git-revision.patch11
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.4.ebuild80
24 files changed, 506 insertions, 1 deletions
diff --git a/app-backup/attic/Manifest b/app-backup/attic/Manifest
new file mode 100644
index 000000000000..1f5d62363ed1
--- /dev/null
+++ b/app-backup/attic/Manifest
@@ -0,0 +1 @@
+DIST attic-0.16.tar.gz 87985 SHA256 ce44800b08540cbe334f0a4f5da49585850c1eea1bf621c2766bbdcc98a13e09 SHA512 16139cd93bff59414cc1ce3fd68e2dd0aed4937a20bd1003880961ad2e239a1e982fd0d4f6b791165464213b88dea6ccd8e5e59d2087809be2e1bfdfd3b3186c WHIRLPOOL e3f0963cca0ede9d5400393cb5aabf66433c87bbc0dd997e2d63991e69d380113c6a25075ecac0ab61e5807676bf2aa87e72257133df0f2ee879ccaef586e5a3
diff --git a/app-backup/attic/attic-0.16.ebuild b/app-backup/attic/attic-0.16.ebuild
new file mode 100644
index 000000000000..b3249988f1c9
--- /dev/null
+++ b/app-backup/attic/attic-0.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
new file mode 100644
index 000000000000..b3249988f1c9
--- /dev/null
+++ b/app-backup/attic/attic-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
diff --git a/app-backup/attic/metadata.xml b/app-backup/attic/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/app-backup/attic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-emulation/xen/xen-4.5.2-r2.ebuild b/app-emulation/xen/xen-4.5.2-r2.ebuild
index 07af8f9be985..d703dcf280c1 100644
--- a/app-emulation/xen/xen-4.5.2-r2.ebuild
+++ b/app-emulation/xen/xen-4.5.2-r2.ebuild
@@ -177,9 +177,14 @@ src_install() {
}
pkg_postinst() {
+ local msg="INSTALL_MASK=/boot/xen-syms"
elog "Official Xen Guide and the unoffical wiki page:"
elog " https://wiki.gentoo.org/wiki/Xen"
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.5.2-r3.ebuild b/app-emulation/xen/xen-4.5.2-r3.ebuild
index 2bd75da2cb0c..434306c66456 100644
--- a/app-emulation/xen/xen-4.5.2-r3.ebuild
+++ b/app-emulation/xen/xen-4.5.2-r3.ebuild
@@ -185,4 +185,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.6.0-r3.ebuild b/app-emulation/xen/xen-4.6.0-r3.ebuild
index 4ca1a84356e7..7ff1d1daea5f 100644
--- a/app-emulation/xen/xen-4.6.0-r3.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r3.ebuild
@@ -182,4 +182,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.6.0-r4.ebuild b/app-emulation/xen/xen-4.6.0-r4.ebuild
index c1c7fa0dbbc7..277e71a12752 100644
--- a/app-emulation/xen/xen-4.6.0-r4.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r4.ebuild
@@ -183,4 +183,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/dev-perl/AnyEvent/AnyEvent-7.80.0.ebuild b/dev-perl/AnyEvent/AnyEvent-7.80.0.ebuild
index e6a077dbf5d9..365369c61f44 100644
--- a/dev-perl/AnyEvent/AnyEvent-7.80.0.ebuild
+++ b/dev-perl/AnyEvent/AnyEvent-7.80.0.ebuild
@@ -11,7 +11,7 @@ inherit perl-module
DESCRIPTION="Provides a uniform interface to various event loops"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ppc64 ~sparc ~x86 ~x86-solaris"
IUSE=""
SRC_TEST="do"
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
index f18c232deac6..74c3d2cc7490 100644
--- a/dev-python/carbon/Manifest
+++ b/dev-python/carbon/Manifest
@@ -1,2 +1,3 @@
DIST carbon-0.9.12.tar.gz 47450 SHA256 df4b521a449b888fc901d11abffc9e7eb070a8670e341caa0e13ab8f3029cddf SHA512 060b3d20cf2bd95be22fba30a24591361c772edaaaa99117616f4a01a31eab9395d84c5eb835408fac2c1bc36b70950e260d56456879489a9ee3248c6c4e3f33 WHIRLPOOL c6021492dc5ed3c9c4cefe173b1e0592b18e6c2d49e48cd74059c4d3822ea0b2cf253bedc9a67f7fa37dd8944e06835a1da959300e3c6e0f1759622b19b0c61e
DIST carbon-0.9.13.tar.gz 47509 SHA256 75aecd8114435430e06803ebaf1e9cac81f58fb231fc93d8904d667d971ae6cd SHA512 89c843ac67ed4b68c28273459e5a96594851e5d2694fdefdfb71cebcdc6555d4aac8c45c1c6d2ca61a15405bac7ba3d27836470fe152d5d7a4936bb2d00e6776 WHIRLPOOL 40000d912f3881dc4f197e1290d3e0fd092ec23bc6574a97fa31d0ffa77fa651abc4d4da529e45d88d74ea763f18cde20daf5fd70549d6afd38f4c5b88d1becb
+DIST carbon-0.9.14.tar.gz 50285 SHA256 e12539ca855f0777e326028a32fbff5022d75b7c3e6fcc7e4704305a650aee9a SHA512 e70275c0acce17287b3036668e45c75b9da9b54523faca0f5bdceda4b6b98c71ebf773740e85063ee3ea4e0bc64adee913bb7f8eab1f7016eb504b06f0b589e3 WHIRLPOOL 998c6a3d0b6cc9aa86cc9b79719e762610cf47012f2eebfd575a6bac3aeb78b64c34e94c5fedc5c88074400920268890e8b84e2f1b32ee4ba24bdd0bef31602d
diff --git a/dev-python/carbon/carbon-0.9.14.ebuild b/dev-python/carbon/carbon-0.9.14.ebuild
new file mode 100644
index 000000000000..93a5d95a4e20
--- /dev/null
+++ b/dev-python/carbon/carbon-0.9.14.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend data caching and persistence daemon for Graphite"
+HOMEPAGE="http://graphite.wikidot.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+# whisper appears to have been missed from listing in install_requires in setup.py
+RDEPEND="
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/whisper[${PYTHON_USEDEP}]
+ dev-python/txAMQP[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ # Do not install the configuration and data files. We install them
+ # somewhere sensible by hand. Patch for this vn. 0.9.14 has been extended
+ # due to redhat's init scripts set to install unconditionally in setup.py
+ "${FILESDIR}"/${P}-no-data-files.patch
+ )
+
+python_prepare_all() {
+ # This sets prefix to /opt/graphite. We want FHS-style paths instead.
+ rm setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/carbon
+ doins conf/*
+
+ dodir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
+
+ newinitd "${FILESDIR}"/carbon.initd carbon-cache
+ newinitd "${FILESDIR}"/carbon.initd carbon-relay
+ newinitd "${FILESDIR}"/carbon.initd carbon-aggregator
+
+ newconfd "${FILESDIR}"/carbon.confd carbon-cache
+ newconfd "${FILESDIR}"/carbon.confd carbon-relay
+ newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
+}
+
+pkg_postinst() {
+ einfo 'This ebuild installs carbon into FHS-style paths.'
+ einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
+ einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
+ einfo '(see /etc/carbon/carbon.conf.example).'
+ einfo ' '
+ einfo 'OpenRC init script supports multiple instances !'
+ einfo 'Example to run an instance b of carbon-cache :'
+ einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
+ einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
+}
diff --git a/dev-python/carbon/files/carbon-0.9.14-no-data-files.patch b/dev-python/carbon/files/carbon-0.9.14-no-data-files.patch
new file mode 100644
index 000000000000..858d362d296d
--- /dev/null
+++ b/dev-python/carbon/files/carbon-0.9.14-no-data-files.patch
@@ -0,0 +1,32 @@
+diff -ur carbon-0.9.14.orig/setup.py carbon-0.9.14/setup.py
+--- setup.py 2015-11-07 13:50:29.000000000 +0800
++++ setup.py 2015-12-27 08:43:46.575905408 +0800
+@@ -13,20 +13,6 @@
+ setup_kwargs = dict()
+
+
+-storage_dirs = [ ('storage/whisper',[]), ('storage/lists',[]),
+- ('storage/log',[]), ('storage/rrd',[]) ]
+-conf_files = [ ('conf', glob('conf/*.example')) ]
+-
+-install_files = storage_dirs + conf_files
+-
+-# Let's include redhat init scripts, despite build platform
+-# but won't put them in /etc/init.d/ automatically anymore
+-init_scripts = [ ('examples/init.d', ['distro/redhat/init.d/carbon-cache',
+- 'distro/redhat/init.d/carbon-relay',
+- 'distro/redhat/init.d/carbon-aggregator']) ]
+-install_files += init_scripts
+-
+-
+ setup(
+ name='carbon',
+ version='0.9.14',
+@@ -39,7 +25,6 @@
+ package_dir={'' : 'lib'},
+ scripts=glob('bin/*'),
+ package_data={ 'carbon' : ['*.xml'] },
+- data_files=install_files,
+ install_requires=['twisted', 'txamqp'],
+ **setup_kwargs
+ )
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index 73445e31e2cb..8816b56a0da8 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1 +1,2 @@
DIST whisper-0.9.13.tar.gz 14028 SHA256 6ba106b7271a69ead72b63f6dd5192aa1816cbec376caa491b4e63af28c17262 SHA512 b4b46bb7f31ecb766495f5f592fb2f9a754f5f38f83f071b533d4302b95808b9b4046bf7769bfa0d7713633344c7c693b57dd550b52acec4617257eba68634c1 WHIRLPOOL c9fdffdcd1bb539037a2e880a82335020c05d2196033842b2da1eb84809184747e7454b3696b11cf3fe9877bf313dea27cac47f7d784b01e9c8fc06796e1e499
+DIST whisper-0.9.15.tar.gz 15655 SHA256 426b92cba867728a90a743e26dba4c71634c411450307934137e73cb3bbc13b2 SHA512 bdc9d299ed713a3fc6104938c347682562d5f17a7f3650d823f9814410dc934899b81bb2f42f52e9cc25313d8ed33f7b4def6d8945561d63f6237492bda2a5e6 WHIRLPOOL 43b1c2c4897f3aa6c714dec8c44d81adc3cf2a5f19c45e93afa874dde6a8c204ce33c70301b206e9a220e75980f086b681a7816966dcebe922553fdffdfba82b
diff --git a/dev-python/whisper/whisper-0.9.15.ebuild b/dev-python/whisper/whisper-0.9.15.ebuild
new file mode 100644
index 000000000000..e16feac7b33e
--- /dev/null
+++ b/dev-python/whisper/whisper-0.9.15.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="http://graphite.wikidot.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
diff --git a/net-analyzer/wireshark/wireshark-2.0.0-r1.ebuild b/net-analyzer/wireshark/wireshark-2.0.0-r1.ebuild
index bf934d23d068..7d7f825b6ee3 100644
--- a/net-analyzer/wireshark/wireshark-2.0.0-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.0.0-r1.ebuild
@@ -52,6 +52,7 @@ CDEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
x11-misc/xdg-utils
diff --git a/net-analyzer/wireshark/wireshark-2.0.0.ebuild b/net-analyzer/wireshark/wireshark-2.0.0.ebuild
index 725a55c02c8c..f0bae7c6b839 100644
--- a/net-analyzer/wireshark/wireshark-2.0.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.0.0.ebuild
@@ -51,6 +51,7 @@ CDEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
x11-misc/xdg-utils
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 7915579bd78a..786f1b1f1169 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -50,6 +50,7 @@ CDEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
x11-misc/xdg-utils
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0-r1.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..5d52ce9ff792
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.6.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd user
+
+DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
+HOMEPAGE="http://dnscrypt.org/"
+SRC_URI="http://download.dnscrypt.org/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins systemd"
+
+CDEPEND="
+ dev-libs/libsodium
+ net-libs/ldns
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README* TECHNOTES THANKS"
+
+pkg_setup() {
+ enewgroup dnscrypt
+ enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_configure() {
+ econf \
+ $(use_enable plugins) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd-1.6.0-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-1.6.0-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver <DNSCRYPT_LOCALIP>"
+ elog
+ elog "where <DNSCRYPT_LOCALIP> is what you supplied in"
+ elog "/etc/conf.d/dnscrypt-proxy, default is \"127.0.0.1\"."
+ elog
+ elog "Also see https://github.com/jedisct1/dnscrypt-proxy#usage."
+}
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.confd-1.6.0-r1 b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.confd-1.6.0-r1
new file mode 100644
index 000000000000..5b1b28dd5ab1
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.confd-1.6.0-r1
@@ -0,0 +1,13 @@
+DNSCRYPT_LOCALIP=127.0.0.1
+DNSCRYPT_LOCALPORT=53
+DNSCRYPT_USER=dnscrypt
+DNSCRYPT_OPTIONS="--ephemeral-keys"
+# Pick exactly ONE of the following sets:
+# option 1) selection from CSV file, uses the first column as the key
+DNSCRYPT_RESOLVER_NAME=cisco # Cisco OpenDNS
+DNSCRYPT_RESOLVERS_LIST=/usr/share/dnscrypt-proxy/dnscrypt-resolvers.csv
+# option 2) manually specified parameters
+#DNSCRYPT_RESOLVERIP=203.0.133.53
+#DNSCRYPT_RESOLVERPORT=443
+#DNSCRYPT_PROVIDER_NAME=2.dnscrypt-cert.example.com
+#DNSCRYPT_PROVIDER_KEY=1234:5678:90AB:CDEF:DEAD:BEEF:CAFE:BEA7:1234:5678:90AB:CDEF:DEAD:BEEF:CAFE:BEA7
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.initd-1.6.0-r1 b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.initd-1.6.0-r1
new file mode 100644
index 000000000000..e79f8f98d747
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy.initd-1.6.0-r1
@@ -0,0 +1,60 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DNSCRYPT_LOGFILE=${DNSCRYPT_LOGFILE:-/var/log/dnscrypt-proxy.log}
+DNSCRYPT_RESOLVERS_LIST=${DNSCRYPT_RESOLVERS_LIST:-/usr/share/dnscrypt-proxy/dnscrypt-resolvers.csv}
+
+rundir=${rundir:-/var/run/dnscrypt-proxy}
+pidfile=${pidfile:-${rundir}/dnscrypt-proxy.pid}
+rundir=${rundir:-/var/run/dnscrypt-proxy}
+runas_user=${runas_user:-dnscrypt}
+runas_group=${runas_user:-dnscrypt}
+
+depend() {
+ use net
+ before dns
+ after logger
+}
+
+start() {
+ if [ ! -d "${rundir}" ]; then
+ mkdir "${rundir}"
+ if [ -n "${runas_user}" ]; then
+ touch "${DNSCRYPT_LOGFILE}"
+ chown ${runas_user}:${runas_group} "${DNSCRYPT_LOGFILE}"
+ chown -R ${runas_user}:${runas_group} "${rundir}"
+ fi
+ fi
+
+ if [ -n "$DNSCRYPT_RESOLVER_NAME" -a -n "$DNSCRYPT_RESOLVERIP" ]; then
+ eerror "You must set exactly one of DNSCRYPT_RESOLVER_NAME or DNSCRYPT_RESOLVERIP!"
+ return 1
+ elif [ -n "$DNSCRYPT_RESOLVER_NAME" ]; then
+ resolver_opts="--resolvers-list=${DNSCRYPT_RESOLVERS_LIST} --resolver-name=${DNSCRYPT_RESOLVER_NAME}"
+ elif [ -n "$DNSCRYPT_RESOLVERIP" ]; then
+ resolver_opts="--resolver-address=${DNSCRYPT_RESOLVERIP}:${DNSCRYPT_RESOLVERPORT} --provider-name=${DNSCRYPT_PROVIDER_NAME} --provider-key=${DNSCRYPT_PROVIDER_KEY}"
+ else
+ eerror "You must set exactly one of DNSCRYPT_RESOLVER_NAME or DNSCRYPT_RESOLVERIP!"
+ return 1
+ fi
+
+ ebegin "Starting dnscrypt-proxy"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/dnscrypt-proxy \
+ -- \
+ ${DNSCRYPT_OPTIONS} \
+ --pidfile="${pidfile}" \
+ --logfile="${DNSCRYPT_LOGFILE}" \
+ --daemonize --user=${runas_user} \
+ --local-address=${DNSCRYPT_LOCALIP}:${DNSCRYPT_LOCALPORT} \
+ $resolver_opts
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dnscrypt-proxy"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/dnscrypt-proxy
+ eend $?
+}
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
index 2b411b88227b..097bfb444f94 100644
--- a/www-plugins/freshplayerplugin/Manifest
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -1,3 +1,4 @@
DIST freshplayerplugin-0.3.1.tar.gz 2711793 SHA256 4ed582896fff618d8025dd51bbf2fae0c5e36e2875065acc536b2c76befb593c SHA512 78e87548ecd758ad9ff0dab59b1b2f68b8b9a639ff19de08046a7090ab51d87f0e4c879b1b0075151ff17642d50ff937e199733c55c4a9cff94599fd98eae9de WHIRLPOOL d8be949cc9a2087d8f62fcfb4a1786d68574a5ec52dccc45da06df9838ee84e8dd4d7f3c3f86703e428df1b3f4d6d75c1e87d0809d3f78550a16ed278d51b211
DIST freshplayerplugin-0.3.2.tar.gz 2713241 SHA256 b3687b9d67ab88c64fea32b17f281f142bf861e33d9135b00da5d90d385d9ce5 SHA512 9c908ce1a168c0797dc3b0da8e98d722cc32d729acb1c4a8f38b7e95c23fe870baabe4b3f8790d021711578fdb9a61f44aba27cebb924fec9aabcf8cd91323e5 WHIRLPOOL 2e9b78bcc3605409ec6853caf31aab03658c044e0d05449a620b31261323856503db8db960db9992d6db4fd61df8f9feb05800124c2f4a450c4ff65b22fc7c34
DIST freshplayerplugin-0.3.3.tar.gz 2722467 SHA256 0dc20d6ca083b24225d8bbab88be1ed483034bde71eb360962de47cdb2e51f00 SHA512 ae85adb7e894adf8c1cd4228d15975c9d5fefdb6c6d3aa90e65d93865996c787f6378eb145f35ed348db67cec0adad794b78a0f77519236c28082630ad3756bc WHIRLPOOL 3e9694738d5e926b44588560b2a6bf50eeeefc35855722bda2494a9d08bd11c8ed844791cdd8a312592be0ef002d3ee6b1c7fc090bbd94ca438ccc8a148eac99
+DIST freshplayerplugin-0.3.4.tar.gz 768318 SHA256 6f0009e64c59caa5c674b63eabb709ba8da6c85fc7cd45a1d66392e3a24da9a5 SHA512 d64fa3e6e38b4e17bef04b09c529ff03e86bb4b348e1e6b9a05f7ff4ee98327e288becd1cc6727db687ddca9e9ed04243c80c5e95e927cafad49a273d9c0d216 WHIRLPOOL 8fe0d582c25042b233d11fba83c50bd5a54e111c7f84b27ed28ba6cfc83c2101095e0460c67d122a3598d020d061f44e8de8bc922a164a251aeb589ac805291d
diff --git a/www-plugins/freshplayerplugin/files/0.3.4-cmake.patch b/www-plugins/freshplayerplugin/files/0.3.4-cmake.patch
new file mode 100644
index 000000000000..59a1a428e55d
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/0.3.4-cmake.patch
@@ -0,0 +1,70 @@
+diff -uarN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2015-04-25 11:17:24.000000000 -0400
++++ b/CMakeLists.txt 2015-04-26 20:14:43.152014529 -0400
+@@ -61,35 +61,36 @@
+ # optional dependencies
+ message(STATUS "checking for optional dependencies")
+
+-pkg_check_modules(PULSEAUDIO QUIET libpulse)
+-pkg_check_modules(JACK QUIET jack)
+-pkg_check_modules(SOXR QUIET soxr)
+ set(WITH_PULSEAUDIO TRUE CACHE STRING "enable PulseAudio support")
+ set(WITH_JACK TRUE CACHE STRING "enable JACK Audio Connection Kit")
+
+-if (PULSEAUDIO_FOUND AND WITH_PULSEAUDIO)
++if (WITH_PULSEAUDIO)
++ pkg_check_modules(PULSEAUDIO libpulse)
++ if (NOT PULSEAUDIO_FOUND)
++ message(FATAL_ERROR "PulseAudio requested but not found.")
++ endif()
+ add_definitions(-DHAVE_PULSEAUDIO=1)
+- message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION} (optional)")
++ message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION}")
+ list(APPEND REQ_LIBRARY_DIRS ${PULSEAUDIO_LIBRARY_DIRS})
+ list(APPEND REQ_INCLUDE_DIRS ${PULSEAUDIO_INCLUDE_DIRS})
+ list(APPEND REQ_LIBRARIES ${PULSEAUDIO_LIBRARIES})
+-else()
+- message(STATUS " no libpulse found (optional)")
+ endif()
+
+-if (JACK_FOUND AND WITH_JACK)
+- message(STATUS " found jack, version ${JACK_VERSION} (optional)")
+- if (SOXR_FOUND)
+- message(STATUS " found soxr, version ${SOXR_VERSION}")
+- add_definitions(-DHAVE_JACK=1)
+- list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
+- list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
+- list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+- else()
+- message(STATUS " no soxr found, JACK output disabled")
++if (WITH_JACK)
++ pkg_check_modules(JACK QUIET jack)
++ if (NOT JACK_FOUND)
++ message(FATAL_ERROR "JACK support requested but not found.")
++ endif()
++ pkg_check_modules(SOXR QUIET soxr)
++ if (NOT SOXR_FOUND)
++ message(FATAL_ERROR "SOXR libray not found but needed for JACK support.")
+ endif()
+-else()
+- message(STATUS " no jack found (optional)")
++ message(STATUS " found jack, version ${JACK_VERSION}")
++ message(STATUS " found soxr, version ${SOXR_VERSION}")
++ add_definitions(-DHAVE_JACK=1)
++ list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
++ list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
++ list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+ endif()
+
+ list(APPEND REQ_LIBRARIES img-resources)
+--- a/src/CMakeLists.txt 2015-12-20 08:38:33.000000000 -0500
++++ b/src/CMakeLists.txt 2015-12-26 20:45:07.000000000 -0500
+@@ -5,7 +5,7 @@
+
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+
+-set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/mozilla/plugins/" CACHE PATH "plugin install directory")
++set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/nsbrowser/plugins/" CACHE PATH "plugin install directory")
+
+ add_subdirectory(uri_parser)
+ add_subdirectory(config_parser)
diff --git a/www-plugins/freshplayerplugin/files/0.3.4-git-revision.patch b/www-plugins/freshplayerplugin/files/0.3.4-git-revision.patch
new file mode 100644
index 000000000000..96cfce94c936
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/0.3.4-git-revision.patch
@@ -0,0 +1,11 @@
+--- a/cmake/update-version-info.sh 2015-12-20 08:38:33.000000000 -0500
++++ b/cmake/update-version-info.sh 2015-12-26 20:14:00.000000000 -0500
+@@ -18,7 +18,7 @@
+ GIT_COMMAND_EXISTS=1
+ command -v git >/dev/null 2>&1 || GIT_COMMAND_EXISTS=0
+
+-if [ $GIT_COMMAND_EXISTS -eq 0 ]; then
++if [ $GIT_COMMAND_EXISTS -eq 0 -o ! -d "${CMAKE_SOURCE_DIR}/.git" ]; then
+ update_header "no vcs hash"
+ exit 0
+ fi
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.4.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.4.ebuild
new file mode 100644
index 000000000000..3428e4c95186
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.8"
+
+inherit cmake-utils multilib
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gtk3 jack libav libressl pulseaudio vaapi vdpau"
+
+KEYWORDS="~amd64 ~x86"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?,x264] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?,x264] )
+ x11-libs/libva
+ x11-libs/libvdpau
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2=
+ dev-libs/libevent:=[threads]
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/libv4l:0=
+ media-libs/mesa:=[egl,gles2]
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/libdrm:=
+ x11-libs/pango:=[X]
+ jack? (
+ media-sound/jack-audio-connection-kit
+ media-libs/soxr
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ !gtk3? ( x11-libs/gtk+:2= )
+ gtk3? ( x11-libs/gtk+:3= )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${COMMON_DEPEND}
+ || (
+ www-plugins/chrome-binary-plugins[flash]
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ )
+ "
+
+PATCHES=( "${FILESDIR}/0.3.4-cmake.patch" "${FILESDIR}/0.3.4-git-revision.patch" )
+DOCS=( ChangeLog data/freshwrapper.conf.example README.md )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with jack JACK)
+ $(cmake-utils_use_with pulseaudio PULSEAUDIO)
+ -DWITH_GTK=$(usex gtk3 3 2)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}