summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/opencpn-plugin-dr/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-1.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-dr/Manifest b/sci-geosciences/opencpn-plugin-dr/Manifest
new file mode 100644
index 000000000000..984e728dab30
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-dr/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-dr-1.1.tar.gz 133693 SHA256 57b42b577228e105b22b58b66148527ae62eb119d3f35a5c688360ed251b64d5 SHA512 2a953c7a8a491975c2b14e877364cfa736d2c410ea77bb4e0b18cf3bb3b04b19c2fcbc9debd513182f95002b483e689c4e21c30d87474e319bae7d2d840254f1 WHIRLPOOL db083b87f17b3fbe5895e9ccee58b2d42283653832731baeaffb997a63ba9e1e003b9efe60c58b3ea640bfdb88ec495030009a22e0962898dcc9cfbdc9286889
diff --git a/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-1.1.ebuild b/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-1.1.ebuild
new file mode 100644
index 000000000000..80538b7067fd
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="DR_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/Rasbats/${MY_PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Dead Reckoning Positions Plugin for OpenCPN"
+HOMEPAGE="https://github.com/Rasbats/DR_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}