summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.9.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index fbf672b0d8b0..e26997b1fc40 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -4,3 +4,4 @@ DIST cffi-1.6.0.tar.gz 397024 SHA256 a7f75c4ef2362c0a0e54657add0a6c509fecbfa3b38
DIST cffi-1.7.0.tar.gz 400251 SHA256 6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df SHA512 ce9439a219248b06a6f2d019324f4150576b5e4d853025d61d470105f95af2a6c2387080bfd0308c063ad756f34feead9a5958187d626524594dfe9a3adf7462 WHIRLPOOL 1d10ba1d5fe2dadfe239c2111e9eb08beeddb7b796e966dae642fbfef0d590737018e27e3036817a1b2f43d76d2526642022b0d2ebe97ce8fcf4a49c8006ea26
DIST cffi-1.8.2.tar.gz 403191 SHA256 2b636db1a179439d73ae0a090479e179a43df5d4eddc7e4c4067f960d4038530 SHA512 a7bbb8735cf4b36510b6953db26af2428725d589fedae05693f39c77b84567bdefd6e3dc1e5c6deef94e617ceb4bf6bf92379e76fd3732d73a19e8a39a3d06ed WHIRLPOOL 5442e4c5ab58fad20b05cc545721417e73992ef3584dc24501124075647d667a640230ff3a67e362c376aa32aff0c7d93b17425682f132532e2c165cd954b3dc
DIST cffi-1.8.3.tar.gz 403766 SHA256 c321bd46faa7847261b89c0469569530cad5a41976bb6dba8202c0159f476568 SHA512 a5a5f62c9d8607a8477abc2c2c53dcbe2aa4cf964b0592d4db349cd35a199e69a84d6cf160973fb5ee736607fa6a41314e8ff0d84bef2ffe16c08f6071c15222 WHIRLPOOL 9ab2f3bf534f4c7b925f3617a109c31ed6591500c551e0c1cae2443b506fa5aea8a1b91b9c378646354effba3d12f0002727be0560359ed40eb3c8751a352c03
+DIST cffi-1.9.1.tar.gz 407108 SHA256 563e0bd53fda03c151573217b3a49b3abad8813de9dd0632e10090f6190fdaf8 SHA512 6e76f181b6b7b760a14ad70338edd104a8b8e2eac5680e336d3868e0bd031a1665608e29a65dc0c56806afb8a8c03811586f151f3acef11e54e60c1bfcf902e3 WHIRLPOOL 12f9c044b7552520e5fe373fe85b0437734cee79a3f9a7eb1ec107ee877c85830e7f5d327d4a4a9504176cdb207a44e169ab52896a78459f00af285fd660c106
diff --git a/dev-python/cffi/cffi-1.9.1.ebuild b/dev-python/cffi/cffi-1.9.1.ebuild
new file mode 100644
index 000000000000..640db6d03477
--- /dev/null
+++ b/dev-python/cffi/cffi-1.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ einfo "$PYTHONPATH"
+ $PYTHON -c "import _cffi_backend as backend" || die
+ PYTHONPATH="${PYTHONPATH}" \
+ py.test -x -v \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}