summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch32
-rw-r--r--dev-python/fsspec/fsspec-2021.06.1.ebuild51
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 4f23bc45b1e3..418da215814f 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2021.05.0.tar.gz 292796 BLAKE2B 5d56d860ced1a72c27d2031b7d257a4bcbd52f6b2fed5275fbcbf7088375fde26652f0a003e919ebd3948d5e9833d802304234282ca858a7a2a19bfa11f66aa8 SHA512 7c27a1ad4e21efdcc0f31f91a9929e4c09db7b9421e7bf8d2f485e961f6887a4a5c083f38f8d7b09005a4cf11f55c93cce4617e3dc6c2b241ed20f7847ad711e
+DIST filesystem_spec-2021.06.1.tar.gz 297254 BLAKE2B e360c0780df2ace31a2a7e15f7269f23140ddbc6bd6a1f657cfddbab2b1f285d79a0c88f8d63e406d4a53fd3737f77012eb9837479707a778ab043503ade9d18 SHA512 1d59c2c53b1a4a604ff3762eca8484d7ed60fba98548cc77d7ed014ddf1513cef046ceeec41911cdecd414bdbb4e3c669a3a3f65da08dabf5a70cc2985d06b73
diff --git a/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch b/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch
new file mode 100644
index 000000000000..0c76d8ac71df
--- /dev/null
+++ b/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch
@@ -0,0 +1,32 @@
+From 270423008d401d9f03a31f08c53a7b13fa193573 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 23 Jun 2021 09:23:31 +0200
+Subject: [PATCH] Fix test_unmodel to accept ujson encoding without whitespace
+
+The ujson encoding for test_unmodel data is b'"Conventions":"UGRID-0.9.0"'
+(without a space after ':') that breaks the test for me. Update
+the test to make the whitespace optional.
+
+That said, I have tried multiple ujson versions, going back to <3,
+and was not able to reproduce the output with space.
+---
+ fsspec/implementations/tests/test_reference.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/fsspec/implementations/tests/test_reference.py b/fsspec/implementations/tests/test_reference.py
+index a1a8fdc..15a32d5 100644
+--- a/fsspec/implementations/tests/test_reference.py
++++ b/fsspec/implementations/tests/test_reference.py
+@@ -104,7 +104,8 @@ jdata = """{
+
+ def test_unmodel():
+ refs = _unmodel_hdf5(json.loads(jdata))
+- assert b'"Conventions": "UGRID-0.9.0"' in refs[".zattrs"]
++ # apparently the output may or may not contain a space after ':'
++ assert b'"Conventions":"UGRID-0.9.0"' in refs[".zattrs"].replace(b' ', b'')
+ assert refs["adcirc_mesh/0"] == ("https://url", 8928, 8932)
+
+
+--
+2.32.0
+
diff --git a/dev-python/fsspec/fsspec-2021.06.1.ebuild b/dev-python/fsspec/fsspec-2021.06.1.ebuild
new file mode 100644
index 000000000000..38f77d30991b
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.06.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ujson.patch
+)
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ epytest \
+ --deselect fsspec/tests/test_spec.py::test_find \
+ --ignore fsspec/implementations/tests/test_dbfs.py \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py
+}