summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/lldb/lldb-10.0.0.9999.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-util/lldb/lldb-10.0.0.9999.ebuild b/dev-util/lldb/lldb-10.0.0.9999.ebuild
index 537fb0c30af1..b28959dc3c26 100644
--- a/dev-util/lldb/lldb-10.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-10.0.0.9999.ebuild
@@ -106,15 +106,5 @@ src_test() {
src_install() {
cmake-utils_src_install
- # oh my...
- if use python; then
- # remove custom readline.so for now
- # TODO: figure out how to deal with it
- # upstream is basically building a custom readline.so with -ledit
- # to avoid symbol collisions between readline and libedit...
- rm "${D}$(python_get_sitedir)/readline.so" || die
-
- # byte-compile the modules
- python_optimize
- fi
+ use python && python_optimize
}