summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-electronics/gazebo/files/tinyxml2.patch22
-rw-r--r--sci-electronics/gazebo/gazebo-7.3.1.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/files/tinyxml2.patch b/sci-electronics/gazebo/files/tinyxml2.patch
new file mode 100644
index 000000000000..b829201f4905
--- /dev/null
+++ b/sci-electronics/gazebo/files/tinyxml2.patch
@@ -0,0 +1,22 @@
+Index: gazebo-7.3.1/gazebo/util/LogPlay.cc
+===================================================================
+--- gazebo-7.3.1.orig/gazebo/util/LogPlay.cc
++++ gazebo-7.3.1/gazebo/util/LogPlay.cc
+@@ -72,7 +72,7 @@ void LogPlay::Open(const std::string &_l
+
+ // Flag use to indicate if a parser failure has occurred
+ bool xmlParserFail = this->dataPtr->xmlDoc.LoadFile(_logFile.c_str()) !=
+- tinyxml2::XML_NO_ERROR;
++ tinyxml2::XML_SUCCESS;
+
+ // Parse the log file
+ if (xmlParserFail)
+@@ -105,7 +105,7 @@ void LogPlay::Open(const std::string &_l
+
+ // Retry loading the log file.
+ xmlParserFail = this->dataPtr->xmlDoc.LoadFile(_logFile.c_str()) !=
+- tinyxml2::XML_NO_ERROR;
++ tinyxml2::XML_SUCCESS;
+ }
+ }
+ }
diff --git a/sci-electronics/gazebo/gazebo-7.3.1.ebuild b/sci-electronics/gazebo/gazebo-7.3.1.ebuild
index c3b8b54a0534..cdc015cda205 100644
--- a/sci-electronics/gazebo/gazebo-7.3.1.ebuild
+++ b/sci-electronics/gazebo/gazebo-7.3.1.ebuild
@@ -54,6 +54,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/tinyxml2.patch" )
src_configure() {
# doesnt build without it