summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.7.8.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 6d958057a3a5..8907dcc6a65f 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -3,3 +3,4 @@ DIST drupal-8.6.16.tar.gz 17151378 BLAKE2B 2bdd14ff7a5f898af2d322a6b2862643899df
DIST drupal-8.7.5.tar.gz 17843250 BLAKE2B e68895ae3d097c1bb4269bd77a2180723caa3601322443eaced9e6e157511468b2fe877ee72dafb735c6d7d077c1f3d29e3de6b3624bbcc0f080ec4deb305065 SHA512 f0f34f8314e86b9fa104992fe8f96dfada335f58c5e25c174f44e484c27dd4a2c9f4fb19505ac29636fc7f9548c898fbf497c119ac8dd588e881e7aa373aefde
DIST drupal-8.7.6.tar.gz 17866782 BLAKE2B 19a616fd685078bdffa9f9e20234aa0aca8f24bc040068f7496cfb7163216977c4bfaf63f564b5fea08351f1899bb97bc50f48ae21250213ed8b93bbb15ab54f SHA512 eec8c5d5646371cb8382806c93e925d65b725878b2a4e53f4ad5559f14523c31e62cbba7ec813292b79cf1a332f64098e41720472171f233ce0bc1c0d24c395e
DIST drupal-8.7.7.tar.gz 17873760 BLAKE2B b3614217ec84396714ed0bc9dfa95bd2ef6b9d41e842b7bb7301cd7d00505afbb4902613f814f438e3a9c4091cf48869b8298d0f6bcd71570a73eda287adc0f0 SHA512 098fa371159449eb7ff8ca1f25100700a6986a5b1efed9c4989372e1eb53e02ab9fd9ca218c51e59b2a3280e1dc0fdc95382c3bdce30eed2974176ef08b75eb6
+DIST drupal-8.7.8.tar.gz 17882836 BLAKE2B 8a521c5c615356548eea8a64ee81e31082e3b9c5ed37c66fef7f2f3c426c7339e4848b90306cfccae1005c5c6d8fe8d7964662012da66c9c6754c6052d102173 SHA512 cc68e6318ebc162cd50fe19046a992ae2ca338f9da564a12a88954edb2c0cecaa56b0ded22903f67f305ab1fee48dd8a2bbf8b65a9efda2e1ce50d11b97bab28
diff --git a/www-apps/drupal/drupal-8.7.8.ebuild b/www-apps/drupal/drupal-8.7.8.ebuild
new file mode 100644
index 000000000000..904bdb363546
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="-alpha ~amd64 -ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}