summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.7.3.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index d79826f66866..3fc2c91fde21 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -2,3 +2,4 @@ DIST drupal-7.67.tar.gz 3312764 BLAKE2B bb7f21e80ca192ff3e37f917c1fa43dcd8d3cd8b
DIST drupal-8.6.16.tar.gz 17151378 BLAKE2B 2bdd14ff7a5f898af2d322a6b2862643899dfbe2ad05c99b85f036161612cccfc2c25105c8eef37311634a2aa03ed792db8de3e625aed5adb94cd8f644557fcb SHA512 34f260d780bce286a0a61b710c340d2622cb857aa92a2bdaad63737303ef2f4f1751edc3f415daaa14b9cb483757e367e639136d03f571cba5165129bba31e12
DIST drupal-8.7.1.tar.gz 17811529 BLAKE2B 5bdb92a8f6c5675dd311417db526be81149240a053bdb94f4294cb571193ed03f2edbc83b51cbcce9e0e322b45981d0949714659f5db2dff211815232cd447e5 SHA512 a386f7991465eade203aba4b20bb894041c76abda97e93afd772a02b215ac496d57a9aed50820a7bd78604c9e6602180fcda933c5121b8536a7d610a3bc3f2e8
DIST drupal-8.7.2.tar.gz 17824323 BLAKE2B 355a4cdbcefe98afd53235bd8546e50efe911a36536aa07e9cb8a86f00dc6b068d0c276e26aee975790ef80ca5030d7464d4b705fa4da9391ce051994a7b850d SHA512 9dc8ca6c431f1d9e50d1c9139efe537815b59bf17b433cdeeb2df5f60ae9a77812f5ca096b5a0aa67bf71344efe60728e46b209609d41fc25065ae58a6bca6af
+DIST drupal-8.7.3.tar.gz 17825116 BLAKE2B 961d92526d8d53d1823b01696bacf6bcca7c10ea0057c561a9126d43f0e18ab1b37a5e85b733927793348b8241014b78b4efdf8aaedbf9e6e82caed51df76b64 SHA512 f7b1c0360091f7b14109b6a328663d0006138d3a39855838bfa9ec70d17aa835ffe8fb393e3b54a378bdfd3011f6cfe9e2eae9be5e79c8fc2586bc48b0bd7df2
diff --git a/www-apps/drupal/drupal-8.7.3.ebuild b/www-apps/drupal/drupal-8.7.3.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}