summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/taskflow/Manifest1
-rw-r--r--dev-python/taskflow/taskflow-1.22.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/taskflow/Manifest b/dev-python/taskflow/Manifest
index 3f0746bb0243..61fc8d27b9af 100644
--- a/dev-python/taskflow/Manifest
+++ b/dev-python/taskflow/Manifest
@@ -5,4 +5,3 @@ DIST taskflow-0.2.tar.gz 238352 SHA256 7cfbf08bfd52b9f652294cc914ad0e6032c209e5a
DIST taskflow-0.5.0.tar.gz 415045 SHA256 1df392fba696b978be62364abc4d14bec3a4fd9007974631a2405356a43482ce SHA512 d7a0be2cab55c17ed572391bbe8c9d833272897765bb824de1db14f4e056010d736a54098986ea6c07c419b4ca3f62d2d403c884e8fb182bc9b6bf64124ebc74 WHIRLPOOL 82083edb9df4b2c7bb515eedaf6931d0fe83b93bd08fd177c5d0b3cd4dbe6f8946cdfc1f06f37faf61dc3e1394b93630ef739cef2580079feaf677b7b188ed1c
DIST taskflow-0.7.1.tar.gz 631738 SHA256 bf1f833184c12787d09ab1b587b41d4feec631f2b9d7fc55e63ef3098e74ad5b SHA512 f3e06bec83c5ef963a386dafa80239b48595e1a3ed9857a4dabc3bf41114de49cc1d5282ae11508164b926a16c721be7e9d25bf51be0f86b7f7dda8ec5817f59 WHIRLPOOL d4f3e55c479437a2f373ca6f1c559c474ae7c935e79f9b7c26e6fd978c67bf58c63dccc7c755b33d9ccb7bbeab2ac7440b783222a0291e5ac93d02d972ea0a56
DIST taskflow-1.21.0.tar.gz 1022884 SHA256 cda5021fc2a2b1d20d575c3e191aaae280e0552b138907e77cea70301be88721 SHA512 cd22c44ece0ae825aeca7c8d063d92708c1414f3a48d90d4835deff1a373da4cc19f84a3265b2d88451a8186bfc71034fdfc44344594d63b7f13fbde58b762f0 WHIRLPOOL d17d0111c0c5b600cb6027df95519bcae7b5ec22d153b1816e6a750dc0cd7b40c57e821f7efdcc43eb47c7036e400e3f03bef81d251e580f8b08175f2af1ada6
-DIST taskflow-1.22.0.tar.gz 1026371 SHA256 4ddf595f7c06b0f307d779ae9bfb8c4db46c606ca6b2d7bce3d45f22c00dd337 SHA512 92badd09ba4c50712284d66c1d8ec62bb9dd4cb80feb9e2e041eb4745edc0ddc541981960e40d401ca2986f85189382f48d90e87fc50f882d09de9444479f916 WHIRLPOOL c3dce034a241760ac2b9ccfb8f1f8080ba5e51953b2858553ff598469181ade18b5f71d9436c54659a8c330a52c662e78432b07f535d6f9477ce2cc9e94e9763
diff --git a/dev-python/taskflow/taskflow-1.22.0.ebuild b/dev-python/taskflow/taskflow-1.22.0.ebuild
deleted file mode 100644
index d072e3ce5c6d..000000000000
--- a/dev-python/taskflow/taskflow-1.22.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="A library to do [jobs, tasks, flows] in a HA manner using different backends"
-HOMEPAGE="https://github.com/openstack/taskflow"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/kombu-3.0.7[${PYTHON_USEDEP}]
- >=dev-python/zake-0.1.6[${PYTHON_USEDEP}]
- >=dev-python/kazoo-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/alembic-0.7.2[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7' 'python3_3')]
- >=dev-python/networkx-1.8[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
- <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- sed -i '/^hacking/d' requirements* || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testr init
- testr run --parallel || die "failed testsuite under python2.7"
-}