summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/sogo-3.2.8.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index 3de93b655852..19c74cb70109 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1,2 +1,3 @@
DIST sogo-3.2.1.tar.gz 32210103 SHA256 9faef922937f1413c1567e91cf865f577be43cc455c7124e3711bcdb49c7ded3 SHA512 0f8207d1f555982965870971f7130ad7868f4b904e3d6c8a2af9b0226820008174867a8515cd6e7775e9e0e4a3f1de98f73482425bec0c81b6d382ff9fe4a5ee WHIRLPOOL 529b03fd216289701d0af3a77236cc103693a366d597d6992c22d863bb9f7562462c906c1b2e78a72d922770dad953035b3e0c21d9ec3752ff7e8ac0d0bc7686
DIST sogo-3.2.6a.tar.gz 32285592 SHA256 07ba2527dab193c5424bc0dd4a9fb53e266c68936011a7245bf5e81e97366a62 SHA512 9b24ab0111408f18e655a5b5ebfe251fc7b9c21914af1c2f2d23c27a7d2d635a8ec0c0119752c7757d2ed878db018c483a8516911e89f5892c1d8fa878418471 WHIRLPOOL d02f25a4360ceea3ccab8f40b3ec726a4ef7792afb412cf415874727abdce1c828e231058be80b3ec5c970c929a33dc3145b82fac8ec13ffdf8b7a9c7d5bc58a
+DIST sogo-3.2.8.tar.gz 32338801 SHA256 cc974f3e486c1b3897ed27c17cedb46b06580bab18a9a6a022fdebd38316ba3d SHA512 34a964e707879c0b6438fca7e7205f454a6bff080ccfc2bdd0b5bd1ffd2c4fcb6fd381e4f168bb2e716d5083f3bfd9d7887fa31b1cfb216a5810b1ffe7d72ca2 WHIRLPOOL 6c3645f3d25358508538baef2c3aebd7d4744f988745bc9117565ba0d373c010c0894083935ba7469c4199d37bf66623c21566fc0856a100f1397bdc2792d934
diff --git a/gnustep-apps/sogo/sogo-3.2.8.ebuild b/gnustep-apps/sogo/sogo-3.2.8.ebuild
new file mode 100644
index 000000000000..5c728f4bdae5
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-3.2.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die "GNUstep.conf sed failed"
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+}