summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gnome-keyring/Manifest2
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.16.0-r1.ebuild88
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.18.3-r1.ebuild82
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.18.3.ebuild85
4 files changed, 0 insertions, 257 deletions
diff --git a/gnome-base/gnome-keyring/Manifest b/gnome-base/gnome-keyring/Manifest
index 96aa1e799f9f..151b42b87a3b 100644
--- a/gnome-base/gnome-keyring/Manifest
+++ b/gnome-base/gnome-keyring/Manifest
@@ -1,3 +1 @@
-DIST gnome-keyring-3.16.0.tar.xz 1179776 SHA256 15a3bb8c53855a4ff0dbbdfbe4ec3df206c32048f50bdc76a51f8e3e14ece1f5 SHA512 eeb5c614395dda0e046056899f9eb6f962253b48d6b668bb966328e75863010c1f653ba2d8f7ca60bdd8ff5c43f77604396f0e4c448236c5b010dd0c61ffa069 WHIRLPOOL dae5b7294b8274623cd0ccebd57b348b8b73e58bd88f32b12f982f1e0413a042e72adf69a36a21619c34c4726965031e1a5aec476d143f99315a4132bc19df8a
-DIST gnome-keyring-3.18.3.tar.xz 1205108 SHA256 3f670dd61789bdda75b9c9e31e289bf7b1d23ba012433474790081ba7dc0ed98 SHA512 123819218477cd9b617d9cc2c1d10483d9c790bb90edd5b20298a1ba38aeef10dcddf85fcb6b9b92969dd64e53caaaf825b5cbb741e57461050be4973e8c2f78 WHIRLPOOL 01fbda3232cfdb3f2f79f5718c5ad22a871b43ed75722a9ab69f2932f8afc01809b4dc5b5ea1aaf9f17ed8efe973dd12bd700831a9dd62300513d91655359ca6
DIST gnome-keyring-3.20.0.tar.xz 1215324 SHA256 bc17cecd748a0e46e302171d11c3ae3d76bba5258c441fabec3786f418e7ec99 SHA512 f7e6195b4be52edaee3bc3181f006ec31ebd54f8000c98220520f4158f66580b60950e4f55247aefae6aa9320f6589c8a09c1e32853165915ae5ff1b40627c5b WHIRLPOOL 63ceaf842b4f9661eb732fbddec6f26dda7ae157e405eb0d0b377ff07dd01c0e0ae3b3c0dd07d2434199edb3730994231da936aaf472054ee5cb76f089439fb8
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.16.0-r1.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.16.0-r1.ebuild
deleted file mode 100644
index 6c2a7efbbf77..000000000000
--- a/gnome-base/gnome-keyring/gnome-keyring-3.16.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes" # Not gnome macro but similar
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit fcaps gnome2 pam python-any-r1 versionator virtualx
-
-DESCRIPTION="Password and keyring managing daemon"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+caps debug pam selinux +ssh-agent test"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
-COMMON_DEPEND="
- >=app-crypt/gcr-3.5.3:=[gtk]
- >=dev-libs/glib-2.38:2
- app-misc/ca-certificates
- >=dev-libs/libgcrypt-1.2.2:0=
- >=sys-apps/dbus-1.1.1
- caps? ( sys-libs/libcap-ng )
- pam? ( virtual/pam )
-
- >=app-crypt/gnupg-2.0.28
-"
-RDEPEND="${COMMON_DEPEND}
- app-crypt/pinentry[gnome-keyring]
-"
-DEPEND="${COMMON_DEPEND}
- >=app-eselect/eselect-pinentry-0.5
- app-text/docbook-xml-dtd:4.3
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Disable stupid CFLAGS
- sed -e 's/CFLAGS="$CFLAGS -g"//' \
- -e 's/CFLAGS="$CFLAGS -O0"//' \
- -i configure.ac configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- # --disable-gpg-agent, bug #547456
- gnome2_src_configure \
- $(use_with caps libcap-ng) \
- $(use_enable pam) \
- $(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable selinux) \
- $(use_enable ssh-agent) \
- --enable-doc \
- --disable-gpg-agent
-}
-
-src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
-}
-
-pkg_postinst() {
- # cap_ipc_lock only needed if building --with-libcap-ng
- # Never install as suid root, this breaks dbus activation, see bug #513870
- use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
- gnome2_pkg_postinst
-
- if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
- ewarn "Please select pinentry-gnome3 as default pinentry provider:"
- ewarn " # eselect pinentry set pinentry-gnome3"
- fi
-}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.18.3-r1.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.18.3-r1.ebuild
deleted file mode 100644
index 84866571b239..000000000000
--- a/gnome-base/gnome-keyring/gnome-keyring-3.18.3-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes" # Not gnome macro but similar
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit fcaps gnome2 pam python-any-r1 versionator virtualx
-
-DESCRIPTION="Password and keyring managing daemon"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+caps pam selinux +ssh-agent test"
-KEYWORDS="alpha amd64 arm ~arm64 ~ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
-RDEPEND="
- >=app-crypt/gcr-3.5.3:=[gtk]
- >=dev-libs/glib-2.38:2
- app-misc/ca-certificates
- >=dev-libs/libgcrypt-1.2.2:0=
- caps? ( sys-libs/libcap-ng )
- pam? ( virtual/pam )
- >=app-crypt/gnupg-2.0.28:=
-"
-DEPEND="${RDEPEND}
- >=app-eselect/eselect-pinentry-0.5
- app-text/docbook-xml-dtd:4.3
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
- test? ( ${PYTHON_DEPS} )
-"
-PDEPEND="app-crypt/pinentry[gnome-keyring]" #570512
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Disable stupid CFLAGS with debug enabled
- sed -e 's/CFLAGS="$CFLAGS -g"//' \
- -e 's/CFLAGS="$CFLAGS -O0"//' \
- -i configure.ac configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(use_with caps libcap-ng) \
- $(use_enable pam) \
- $(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable selinux) \
- $(use_enable ssh-agent) \
- --enable-doc
-}
-
-src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
-}
-
-pkg_postinst() {
- # cap_ipc_lock only needed if building --with-libcap-ng
- # Never install as suid root, this breaks dbus activation, see bug #513870
- use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
- gnome2_pkg_postinst
-
- if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
- ewarn "Please select pinentry-gnome3 as default pinentry provider:"
- ewarn " # eselect pinentry set pinentry-gnome3"
- fi
-}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.18.3.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.18.3.ebuild
deleted file mode 100644
index 4d11f2dab8c7..000000000000
--- a/gnome-base/gnome-keyring/gnome-keyring-3.18.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes" # Not gnome macro but similar
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit fcaps gnome2 pam python-any-r1 versionator virtualx
-
-DESCRIPTION="Password and keyring managing daemon"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+caps pam selinux +ssh-agent test"
-KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ~mips ~ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
-COMMON_DEPEND="
- >=app-crypt/gcr-3.5.3:=[gtk]
- >=dev-libs/glib-2.38:2
- app-misc/ca-certificates
- >=dev-libs/libgcrypt-1.2.2:0=
- caps? ( sys-libs/libcap-ng )
- pam? ( virtual/pam )
-
- >=app-crypt/gnupg-2.0.28
-"
-RDEPEND="${COMMON_DEPEND}
- app-crypt/pinentry[gnome-keyring]
-"
-DEPEND="${COMMON_DEPEND}
- >=app-eselect/eselect-pinentry-0.5
- app-text/docbook-xml-dtd:4.3
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Disable stupid CFLAGS with debug enabled
- sed -e 's/CFLAGS="$CFLAGS -g"//' \
- -e 's/CFLAGS="$CFLAGS -O0"//' \
- -i configure.ac configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(use_with caps libcap-ng) \
- $(use_enable pam) \
- $(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable selinux) \
- $(use_enable ssh-agent) \
- --enable-doc
-}
-
-src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
-}
-
-pkg_postinst() {
- # cap_ipc_lock only needed if building --with-libcap-ng
- # Never install as suid root, this breaks dbus activation, see bug #513870
- use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
- gnome2_pkg_postinst
-
- if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
- ewarn "Please select pinentry-gnome3 as default pinentry provider:"
- ewarn " # eselect pinentry set pinentry-gnome3"
- fi
-}