summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/promu/Manifest1
-rw-r--r--dev-util/promu/promu-0.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
index f8179f31e397..b4487b18ac77 100644
--- a/dev-util/promu/Manifest
+++ b/dev-util/promu/Manifest
@@ -1,2 +1,3 @@
DIST promu-0.1.0.tar.gz 1065003 BLAKE2B f56dfda69dae632b1946182b1a92c059cac52867c677d415c2f321f95800d3902f8f0fbd4d4b670870f3dce34603b0c1a50df9311be70404f27e9f5afbaf4699 SHA512 18ad54b1ec9fe8975a0048b5c85609858cd500a2d3aa34e51e5c2c3d07a0df4337bac9648562e2007d5c8572e07c814c6bba7522b94836c258cde457df5815e2
DIST promu-0.1.0_p20180227.tar.gz 1068386 BLAKE2B b850c1dfa51f86099bd7e32c131ef99a05d4f4caab441a945fddc9a2895e72b74ed3456f18ab69493fc2283902c570e78f99ea303f32998416fdfbf91c3d0cd8 SHA512 6fbe5fe92602437aee90a442028cd846d9d72179b32e601b6167420dab0a3aed22cd9d1c527320ca54a3cfce7b79167753ad9cbeb000762e845056c692212a74
+DIST promu-0.2.0.tar.gz 1072026 BLAKE2B 2b68d992b37421d6b9a08cc9a9134f9ae52643d4c2844c8e1f6f6724f015582c99a8724ab6b8d1ee69437c660e3b972af85949e3221d8d8c709fd8c1a45e1256 SHA512 4da4716a9d4fb96b6016c9bd452fed0403721ab15f95e6955db2ab6e8e482f3bbb35cb4c1c94f690af9520729a93c100015ee48cb69627e129004ae0b15257ae
diff --git a/dev-util/promu/promu-0.2.0.ebuild b/dev-util/promu/promu-0.2.0.ebuild
new file mode 100644
index 000000000000..b00d33f73cfa
--- /dev/null
+++ b/dev-util/promu/promu-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="264dc36af9ea3103255063497636bd5713e3e9c1"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11"
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${EGIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" emake build
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}