summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.18.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 3faaefca324f..bae6148439ca 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,3 +1,4 @@
DIST mate-system-monitor-1.12.2.tar.xz 2114504 SHA256 78b91ae43fd0f06e0577d71d3b92b9c03ff2dc8809ba2b06dc0c4dc9e93683f5 SHA512 f001d36b7a343cba68bf76094abad4e07cc89537c71dba873bb5ffc61045f440a319e3db8d5ee55ff301f52dbdad8b275ca71a4ab6c5fbe34d75c2e65edd7c23 WHIRLPOOL 7270766f4434cb0e489f3f1ef805586987751fbea6a0a020df8fa7fa38dbbf264d0d1f3694fbba8e9d14cf2ddaee217ac562a391b4b87f1033cf2850067ae1a0
DIST mate-system-monitor-1.14.0.tar.xz 2135464 SHA256 ccd7f52836af22d18138e516335ee259448749b6618327feb908ad396d0c650a SHA512 f19fa0241228be8ec8600db43e71495750039288292ba5714489a84acb3e5cc9f4c87d39a63d29a0fc6f907af6ecc319382cd4276ae2de1125bba059d5b24be5 WHIRLPOOL d354dfbf7121b838af6fac73148e381c23df4e3bc50a59f68f6469416f608235a0b6d990214e9de87bc01e1254f16e1ba9d1f631e18554205ae45ebc4b84f149
DIST mate-system-monitor-1.16.0.tar.xz 2120984 SHA256 abbbfeba699f73a6eacb7545927693daba4fb6203a75170a93df4842cacd9fe1 SHA512 6ee8e1d1a3af5e3b295c2cca74b3e6bdf8a09eb6aa7d63f13db006829c2df25b580b72cc8d6e34e2844b243999cd4f059a42aa67a88c60825defdb7880150796 WHIRLPOOL 2fa9402bab4c9a9441e5dae2094cc12862bf484827f3cd5c238ee234792f03b0a751229c08b81d0def97194e6901f61736747a6656a9738d3bd2f52116e30a70
+DIST mate-system-monitor-1.18.0.tar.xz 2133484 SHA256 887c0d91fa866af75cc066591fcd521107976f123784b1b887535a4709cd9bf1 SHA512 95e85b87f52db32f3c192c29b866020b78638462dd362376180087f24c041b690d3bb66d8ad1174abc89051450efe1f19171746204c68455ddcc6e965339db82 WHIRLPOOL dc4791fbb1090264d4b42883c734bb84fa14cd39d37f33335472077592097b8a9c3c2c45723464038f91efecc271b7b92b69fa2e7985f7f74d6e22613b19a147
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.18.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.18.0.ebuild
new file mode 100644
index 000000000000..2f99dc8cf7bc
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.18.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="systemd"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.36:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libwnck-3.0:3
+ virtual/libintl:0
+ systemd? ( sys-apps/systemd )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable systemd)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ einfo "${PN} may run commands with escalated privileges using"
+ einfo "x11-libs/gksu."
+}