summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/kubeadm/Manifest2
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.13.2.ebuild47
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.13.3.ebuild47
3 files changed, 0 insertions, 96 deletions
diff --git a/sys-cluster/kubeadm/Manifest b/sys-cluster/kubeadm/Manifest
index 37bc3f93fac0..7d3db3e831be 100644
--- a/sys-cluster/kubeadm/Manifest
+++ b/sys-cluster/kubeadm/Manifest
@@ -1,4 +1,2 @@
-DIST kubernetes-1.13.2.tar.gz 28771642 BLAKE2B 4a5c5a8e0c05faab3fb6a26854e7c8643b893c2a1f5d5b56aacea869d86426dffe358222034b826d66dfd19855bee71cad7356ff483c27218019e4adda499ce7 SHA512 2f24119fc21d7bdbb60174b46da94ce3f2f6a3c638e9d96323c93c20039aeb06f9c9a3a48c43bb36b71eff25cf72967e780e3339b35ad7ad7a7a7c35662c96bd
-DIST kubernetes-1.13.3.tar.gz 28781320 BLAKE2B 7ae1a6ddeff5b8d19bacc868ad5970cc8ea81239f1ce709207e321ab97c0f155c6c363b3b0f9af25f6e6ce68d99678cf2b10c841a45f082f486bd9dee7be5e3a SHA512 45c2639a88e04d16511c92ca48ca6326b12422f0765df92fb883a1afe7fda9adefcf111d76855532f69b48c6e681774ee0c7e08f74594de808b50e11f8ec52c5
DIST kubernetes-1.13.4.tar.gz 28793464 BLAKE2B 0a637bf1003e4fd6ebabe09ebc0f3ca54e0258e7efb1578be727d5019c1f44638358462acccafa91bed2320d6392c54416079bb54bed12977739092965aeaeb5 SHA512 aa07877bc141ceedab56d9dd65920d86121724a0d20b86ee4925c88d805df8235162f235a957d24c053a60869ab2084062a1607f43c8eeea736fd72eb328c800
DIST kubernetes-1.13.5.tar.gz 28804719 BLAKE2B 9ca1f24a26f5917c085fad65c3ed1cb4cc0f5556f6245b8e87aee5244e96ed6beede646f8b95b118d79ac715e988111f7fd2ddfb4c478af7a9bfe19c4dd227be SHA512 aced7b8dae452c62f4751785ad106c3747054ccb075b3d04dd82bd816d74f4002844e3cfa7aee138c9661e5c30a9aa9743f10a0dd807bbd590fffb60ce72f617
diff --git a/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild b/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild
deleted file mode 100644
index 6c4b699b7594..000000000000
--- a/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot bash-completion-r1
-
-EGO_PN="k8s.io/kubernetes"
-ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="${ARCHIVE_URI}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.11
- dev-go/go-bindata"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
- sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
-}
-
-src_compile() {
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
- pushd src/${EGO_PN} || die
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin _output/bin/${PN}
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- popd || die
-}
diff --git a/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild b/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild
deleted file mode 100644
index 6c4b699b7594..000000000000
--- a/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot bash-completion-r1
-
-EGO_PN="k8s.io/kubernetes"
-ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="${ARCHIVE_URI}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.11
- dev-go/go-bindata"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
- sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
-}
-
-src_compile() {
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
- pushd src/${EGO_PN} || die
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin _output/bin/${PN}
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- popd || die
-}