summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/dbench/dbench-4.0.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-benchmarks/dbench/dbench-4.0.ebuild b/app-benchmarks/dbench/dbench-4.0.ebuild
index ca159a52f2a7..1e2cda61523d 100644
--- a/app-benchmarks/dbench/dbench-4.0.ebuild
+++ b/app-benchmarks/dbench/dbench-4.0.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools toolchain-funcs
DESCRIPTION="Popular filesystem benchmark"
SRC_URI="https://www.samba.org/ftp/pub/tridge/dbench/${P}.tar.gz"
HOMEPAGE="https://www.samba.org/ftp/tridge/dbench/"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86"
-IUSE=""
DEPEND="dev-libs/popt"
RDEPEND="${DEPEND}"
src_prepare() {
- eautoheader
- eautoconf
- sed -i -e \
- "s:\$(CC) -o:\$(CC) \$(LDFLAGS) -o:" \
- Makefile.in || die
+ default
+
+ sed -i -e "s:\$(CC) -o:\$(CC) \$(LDFLAGS) -o:" Makefile.in || die
+ mv configure.{in,ac} || die
+
eautoreconf
}
@@ -38,5 +38,5 @@ src_install() {
}
pkg_postinst() {
- elog "You can find the client.txt file in ${ROOT}usr/share/dbench."
+ elog "You can find the client.txt file in ${EROOT}/usr/share/dbench."
}