summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/narray/Manifest1
-rw-r--r--dev-ruby/narray/narray-0.6.1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/narray/Manifest b/dev-ruby/narray/Manifest
index 142d65217258..80a0c690d059 100644
--- a/dev-ruby/narray/Manifest
+++ b/dev-ruby/narray/Manifest
@@ -1,2 +1,3 @@
DIST narray-0.6.0.8.tar.gz 68519 SHA256 0e7ec5d8554ad273ef74b3513d297e60769373fd8b258cfb2afcdd7b8320d642 SHA512 a2f194c0baea7c561d1ef70554e6d568876dd7192506c1e5432bcaccabae03a3e842e73d9cbccd110ac8924d86d18c559109244e302a4ad8aaa3acf304dd4618 WHIRLPOOL 8f722ac74f66759521bf467db3d5266538ab99b959ccbaa1c53d3ef26dab365996d34b37e65c49c739b1b0fecaeb72b0974bd7db897b3132caf3a29600ff8573
DIST narray-0.6.1.1.tar.gz 68536 SHA256 7c2f415666c834d982cba97de3bbda9160e76358c62f8f754cd0d11e90e95ed6 SHA512 1c9983d29c774cb61b7f8ec53290d427c123b648d88407ff4a2e2aef1a289267050d4846adfc00c075629cb228ed5b3d4f9f5ded4cded0b84ec1a5532cbb49ff WHIRLPOOL cdfdc8050daafb10629228bac4bc146a2d8b3461d3c365207ee1112e5f226da82183450f28b98fce98719ae10fbfd31c76ec6567d40e0cf63efe89f018c5db8a
+DIST narray-0.6.1.2.tar.gz 68621 SHA256 7ac717a8690ad5c85ae528102ef42ea50128c979a383abd35585db68cfd31f76 SHA512 51e9bec0b711e79e268b73496ad742b80bb46a6e9ea6aab9a2535a700b6efc8f7ae2e854f5772d434e3d385d81275744dbc796ebec4d3de73f2ec0546bd2339a WHIRLPOOL 8c339a8377dbdc5ee61a4d09085de40cdcbe30ecaaae091dd62c6348e7579174ad0620d6b4c0175a9f90c224b9d9fa49d818f1455f3303d71f4d5d8bc50b92aa
diff --git a/dev-ruby/narray/narray-0.6.1.2.ebuild b/dev-ruby/narray/narray-0.6.1.2.ebuild
new file mode 100644
index 000000000000..d00619a7ce81
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md README.ja.md SPEC.en.txt SPEC.ja.txt"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="https://github.com/masa16/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those and
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ -e '/next will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}