summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/novnc/files/noVNC.initd1
-rw-r--r--www-apps/novnc/novnc-9999.ebuild34
2 files changed, 14 insertions, 21 deletions
diff --git a/www-apps/novnc/files/noVNC.initd b/www-apps/novnc/files/noVNC.initd
index 37367c93c2d5..7789b13587c0 100644
--- a/www-apps/novnc/files/noVNC.initd
+++ b/www-apps/novnc/files/noVNC.initd
@@ -17,6 +17,7 @@ depend() {
}
checkconfig() {
+ checkpath -d -m 0750 /var/log/noVNC
if [ ! -r /etc/conf.d/${SVCNAME} ]; then
eerror "No config file found: /etc/conf.d/${SVCNAME}"
return 1
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
index 95f699248d74..26e0aa8ed975 100644
--- a/www-apps/novnc/novnc-9999.ebuild
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit git-2
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 git-2
DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
HOMEPAGE="https://kanaka.github.com/noVNC/"
@@ -18,42 +20,32 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
- dev-python/numpy"
-
-src_compile() {
- cd "${S}/utils"
- emake
-}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
src_install() {
- dodir /usr/share/novnc
dodir /usr/share/novnc/utils
dodir /usr/share/novnc/include
dodir /usr/share/novnc/images
exeinto /usr/share/novnc/utils
+ doexe utils/b64-to-binary.pl
+ doexe utils/img2js.py
+ doexe utils/inflator.partial.js
doexe utils/json2graph.py
doexe utils/launch.sh
- doexe utils/nova-novncproxy
- doexe utils/rebind
- doexe utils/rebind.so
+ doexe utils/parse.js
doexe utils/u2x11
- doexe utils/web.py
- doexe utils/wsproxy.py
- doexe utils/websocket.py
docinto /usr/share/novnc/docs
dodoc README.md
dodoc LICENSE.txt
+ cp -pPR *.html "${D}/usr/share/novnc/"
+ cp -pPR include/* "${D}/usr/share/novnc/include/"
+ cp -pPR images/* "${D}/usr/share/novnc/images/"
dosym /usr/share/novnc/images/favicon.ico /usr/share/novnc/
- cp -pPR "*.html" "${D}/usr/share/novnc/"
- cp -pPR "include/*" "${D}/usr/share/novnc/include"
- cp -pPR "images/*" "${D}/usr/share/novnc/images"
newconfd "${FILESDIR}/noVNC.confd" noVNC
newinitd "${FILESDIR}/noVNC.initd" noVNC
-
- diropts -m 0750
- dodir /var/log/noVNC
}