summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-eselect/eselect-java/Manifest1
-rw-r--r--app-eselect/eselect-java/eselect-java-0.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/Manifest b/app-eselect/eselect-java/Manifest
index 91bf0e9eefd7..9250d9db6909 100644
--- a/app-eselect/eselect-java/Manifest
+++ b/app-eselect/eselect-java/Manifest
@@ -1 +1,2 @@
DIST eselect-java-0.2.0.tar.bz2 13353 SHA256 a860fdf1d5d0560e206fee3912eb768492115bcb430cb9eba031d0cbf90499bf SHA512 376c72317461c743dd91f8576cff7b1279b8f1672aa878c492ec3ed0da5f3c8d25cbb5fd4d9120109a01466dadbd049fb75d642187c850676d939925bcb55fdd WHIRLPOOL c45da204c312c1277f532756363932aeb057261728f1264cbcc01da6feb7568673aff880fa611c471b60a878434eacda592e3743022130c78247b047dbf848be
+DIST eselect-java-0.3.0.tar.bz2 13434 SHA256 e2c5ec1819cceec29d4f6fab6259c7c7fd670e8d2bce0cba99140a6ad960de9e SHA512 d874d1d20d3920d16d5812b2aa28455f9166c6590b711e2bd49b1632e164be18f177eec5f5f2814391966ca3b710aab21b44d29afead2148cc7d0ed90841f9d8 WHIRLPOOL b1b42b5544103c1ab4102dc5c25d24669e6823d4655e9a7357acff3a349975aecc01eb03f935ae69b5dc102e29cfcc71f72d25b041b419ecb0d4112dd332c4a2
diff --git a/app-eselect/eselect-java/eselect-java-0.3.0.ebuild b/app-eselect/eselect-java/eselect-java-0.3.0.ebuild
new file mode 100644
index 000000000000..cac62cca9003
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ !app-eselect/eselect-ecj
+ !app-eselect/eselect-maven
+ !<dev-java/java-config-2.2
+ app-admin/eselect"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # Bug 549498: "eselect XXX show" should never send output to stderr.
+ sed -i \
+ -e '/^do_show.. {$/,/^}$/{ /echo/s,>&2$,, }' \
+ "${S}"/src/modules/maven.eselect.in \
+ "${S}"/src/modules/ecj.eselect.in
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ "${REMOVED}" = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}