summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/pshs/pshs-0.3-r1.ebuild39
-rw-r--r--www-servers/pshs/pshs-9999.ebuild8
2 files changed, 44 insertions, 3 deletions
diff --git a/www-servers/pshs/pshs-0.3-r1.ebuild b/www-servers/pshs/pshs-0.3-r1.ebuild
new file mode 100644
index 000000000000..d07609f7153a
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}
diff --git a/www-servers/pshs/pshs-9999.ebuild b/www-servers/pshs/pshs-9999.ebuild
index 6d71ea0c59aa..8e23ff2e77a3 100644
--- a/www-servers/pshs/pshs-9999.ebuild
+++ b/www-servers/pshs/pshs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,13 +17,15 @@ SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+magic +netlink qrcode ssl upnp"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
RDEPEND=">=dev-libs/libevent-2:0=
magic? ( sys-apps/file:0= )
qrcode? ( media-gfx/qrencode:0= )
ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
- dev-libs/openssl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
upnp? ( net-libs/miniupnpc:0= )"
DEPEND="${RDEPEND}
netlink? ( sys-apps/iproute2