summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.0.7.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 3cdcaa6dd574..2e009da8c786 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,2 +1,3 @@
DIST mongo-tools-3.0.5.tar.gz 2160877 SHA256 a0a46dabe493d32bda8dec4ca2e4b06c150b405d8184769d50936eb9bc6d126e SHA512 6434708f60c3edc08f439ecd1ae06f634a1897449f1244d9dc3c3024d6146329cfdadaff14a50ba7f35a4bee2bb302b00141d9f388d99a50c4391218c5e9d3e3 WHIRLPOOL d66563c12021bc84a951c7bd125827f958808e577c391252d815a89916fdb86187269d75f9d36a33828132d98040d328cc090ff4fdbc764e3bab15f5fcdb623c
DIST mongo-tools-3.0.6.tar.gz 2161424 SHA256 ed4ebb42efe99f1eeac5ed128f4ae9b10e172396ad06eaae61d3a30c301c2a12 SHA512 ad9e635a6be911116e4a5ddaa4f509c6418036bf9fa4e1ea3940ce3bcc1a5479b403d26d2865b9938a66ed5b38ec4830b307baa7552cc4cf46cc0353dea8853f WHIRLPOOL 29e5364825795c5661ca595e294115d2a06ea43f0b0039bd56d31fd50c1325709a053ebbfc23d54954c4783229be218a6b426ffc6f301149fd946927aad62283
+DIST mongo-tools-3.0.7.tar.gz 2183495 SHA256 3136b8df6e7c81b5cf6609b3cd6113d69ea6c067d5bfd25b2e0dbabef9173ca0 SHA512 ff410f25a42e76f55716e6e478564aaeefd3999cf0e9db718969877709974d099c479690e81d6f639c27b0a4d9b59d193c43f1c31dc027b594f1fef33129cb5a WHIRLPOOL 3e3ac13de56c7abd5fd80dcfe5f94090aa78d240598ed0c879365b275bfab5da07aaf8c5b94ad27e3a6f7c0d24d6a68bbb5e54612b4fa2928efbf880c5c40dfc
diff --git a/app-admin/mongo-tools/mongo-tools-3.0.7.ebuild b/app-admin/mongo-tools/mongo-tools-3.0.7.ebuild
new file mode 100644
index 000000000000..658782fe250e
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.0.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.0.0-build.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf}
+}
+
+src_install() {
+ dobin bin/*
+}