summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/dev86/files/dev86-0.16.17-fortify.patch43
-rw-r--r--sys-devel/dev86/files/dev86-0.16.17-make382.patch11
2 files changed, 0 insertions, 54 deletions
diff --git a/sys-devel/dev86/files/dev86-0.16.17-fortify.patch b/sys-devel/dev86/files/dev86-0.16.17-fortify.patch
deleted file mode 100644
index 715d0c4ca687..000000000000
--- a/sys-devel/dev86/files/dev86-0.16.17-fortify.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- dev86-0.16.17/bcc/bcc.c
-+++ dev86-0.16.17/bcc/bcc.c
-@@ -19,6 +19,7 @@
- #ifdef __STDC__
- #include <stdlib.h>
- #ifndef MSDOS
-+#include <limits.h>
- #include <unistd.h>
- #endif
- #else
-@@ -596,12 +597,17 @@
- }
- }
-
--void
--command_reset()
--{
- #ifndef MAXPATHLEN
-+#ifdef PATH_MAX
-+#define MAXPATHLEN PATH_MAX
-+#else
- #define MAXPATHLEN 1024
- #endif
-+#endif
-+
-+void
-+command_reset()
-+{
- char buf[MAXPATHLEN];
- char ** prefix;
- char * saved_cmd;
-@@ -1308,11 +1314,7 @@
-
- for(d=s=ptr; d && *s; s=d)
- {
--#ifdef MAXPATHLEN
- char buf[MAXPATHLEN];
--#else
-- char buf[1024];
--#endif
-
- free(temp);
- d=strchr(s, ':');
diff --git a/sys-devel/dev86/files/dev86-0.16.17-make382.patch b/sys-devel/dev86/files/dev86-0.16.17-make382.patch
deleted file mode 100644
index e7ce0651c6b3..000000000000
--- a/sys-devel/dev86/files/dev86-0.16.17-make382.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libc/i386sys/Makefile
-+++ libc/i386sys/Makefile
-@@ -12,7 +12,7 @@
- DOBJ=opendir.o closedir.o readdir.o
-
- ifeq ($(LIB_CPU)-$(LIB_OS),i386-ELKS)
--OBJ=$(LOBJ3) $(LOBJ) $(EOBJ) $(DOBJ) setjmp3.o
-+OBJ=$(LOBJ) $(LOBJ) $(EOBJ) $(DOBJ) setjmp3.o
- SYSCALLS=syscalls
-
- CFLAGS=$(ARCH) $(CCFLAGS) $(DEFS)