summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/bitlbee/Manifest2
-rw-r--r--net-im/bitlbee/bitlbee-3.4.2-r1.ebuild157
-rw-r--r--net-im/bitlbee/bitlbee-3.5-r1.ebuild167
-rw-r--r--net-im/bitlbee/files/bitlbee-3.2.1-configure.patch17
-rw-r--r--net-im/bitlbee/files/bitlbee-3.4.2-systemd-user.patch10
5 files changed, 0 insertions, 353 deletions
diff --git a/net-im/bitlbee/Manifest b/net-im/bitlbee/Manifest
index 09af66d4a682..232c35070d51 100644
--- a/net-im/bitlbee/Manifest
+++ b/net-im/bitlbee/Manifest
@@ -1,3 +1 @@
-DIST bitlbee-3.4.2.tar.gz 719456 SHA256 69c85554def74f314e3b6e390389a30b0e748f23ef37883e9d7545ee2c45ea57 SHA512 2b839c014cfad037d815aa0e0867dda1b4628ff076d8de6fec1e80ab1499bca565d9afbe104929d492ff68c86b745cc3f76acbeba102766d656f2d359b70302e WHIRLPOOL 43803ba2bbe6297e05e465912d22b0547bb0f9c3cd184a6c0c924dc023b9d505e3666aa732de83c79249e59aa0e2d6f621ee15c508ccc17eed1898b755f0112e
DIST bitlbee-3.5.1.tar.gz 680351 SHA256 9636d7fd89ebb3756c13a9a3387736ca6d56ccf66ec0580d512f07b21db0fa69 SHA512 4eb3b0d3a92910c8dd789cd23338cc6296bf40212c5244fcb27a88ede10e86424ea59c78e719841863701a7fdd8c61819f2775f7b58833e287d9110e49d036f3 WHIRLPOOL fd8645bb72e2cae336a5d627de0631f5858ffaf4d4d43e7efc5656605068179d86d0deff2810f56e5154995ffdd58ee8be90bc459ff9766dacd5e74d08aaefc7
-DIST bitlbee-3.5.tar.gz 657177 SHA256 549d02181ab303dfe8a219faafd7a1aea7ee642eb071b767f668782a57388319 SHA512 7f044474fff5b1213dddc29e19aae102d1bbe4361cddcf9e58f965c01a58b6f7ed41cbf6ecec050a96f91f55dca15f6df948dee105eff001086d9daa15ba0499 WHIRLPOOL 72434e9d7d43a0d1bf6d1f8c0eda10a099fca262d5431430d0001a7dc7b34e7594e5a6dc0942eebc04f7073bc73d4d8b3f7d00991b21b47d1cfb15ea542715c7
diff --git a/net-im/bitlbee/bitlbee-3.4.2-r1.ebuild b/net-im/bitlbee/bitlbee-3.4.2-r1.ebuild
deleted file mode 100644
index 8cf60e732167..000000000000
--- a/net-im/bitlbee/bitlbee-3.4.2-r1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user systemd
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
- inherit git-r3
-else
- SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
- KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-fi
-
-DESCRIPTION="irc to IM gateway that support multiple IM protocols"
-HOMEPAGE="http://www.bitlbee.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE_PROTOCOLS="msn oscar purple twitter +xmpp yahoo"
-IUSE="debug +gnutls ipv6 libevent libressl nss otr +plugins selinux test xinetd
- ${IUSE_PROTOCOLS}"
-
-REQUIRED_USE="
- || ( purple xmpp msn oscar yahoo )
- xmpp? ( !nss )
-"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.16
- purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent:= )
- otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- nss? ( dev-libs/nss )
- !nss? (
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- )
- )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/logger
- xinetd? ( sys-apps/xinetd )"
-
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
-src_prepare() {
- [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${P}-systemd-user.patch
- eapply_user
-}
-
-src_configure() {
- local myconf
-
- # setup plugins, protocol, ipv6 and debug
- myconf+=( --jabber=$(usex xmpp 1 0) )
- for flag in debug ipv6 plugins ${IUSE_PROTOCOLS/+xmpp/} ; do
- myconf+=( --${flag}=$(usex ${flag} 1 0) )
- done
-
- # set otr
- if use otr && use plugins ; then
- myconf+=( --otr=plugin )
- else
- if use otr ; then
- ewarn "OTR support has been disabled automatically because it"
- ewarn "requires the plugins USE flag."
- fi
- myconf+=( --otr=0 )
- fi
-
- # setup ssl use flags
- if use gnutls ; then
- myconf+=( --ssl=gnutls )
- einfo "Using gnutls for SSL support"
- else
- ewarn "Only gnutls is officially supported by upstream."
- if use nss ; then
- myconf+=( --ssl=nss )
- einfo "Using nss for SSL support"
- else
- myconf+=( --ssl=openssl )
- einfo "Using openssl for SSL support"
- fi
- fi
-
- # set event handler
- if use libevent ; then
- myconf+=( --events=libevent )
- else
- myconf+=( --events=glib )
- fi
-
- # not autotools-based
- ./configure \
- --prefix=/usr \
- --datadir=/usr/share/bitlbee \
- --etcdir=/etc/bitlbee \
- --plugindir=/usr/$(get_libdir)/bitlbee \
- --systemdsystemunitdir=$(systemd_get_systemunitdir) \
- --doc=1 \
- --strip=0 \
- "${myconf[@]}" || die
-
- sed -i \
- -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
- Makefile.settings || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-etc install-doc install-dev install-systemd
-
- keepdir /var/lib/bitlbee
- fperms 700 /var/lib/bitlbee
- fowners bitlbee:bitlbee /var/lib/bitlbee
-
- dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
-
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins doc/bitlbee.xinetd bitlbee
- fi
-
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
-
- exeinto /usr/share/bitlbee
- doexe utils/{convert_purple.py,bitlbee-ctl.pl}
-}
-
-pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
- fi
-}
diff --git a/net-im/bitlbee/bitlbee-3.5-r1.ebuild b/net-im/bitlbee/bitlbee-3.5-r1.ebuild
deleted file mode 100644
index 8a915ec5c383..000000000000
--- a/net-im/bitlbee/bitlbee-3.5-r1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user systemd toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
- inherit git-r3
-else
- SRC_URI="https://get.bitlbee.org/src/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-fi
-
-DESCRIPTION="irc to IM gateway that support multiple IM protocols"
-HOMEPAGE="https://www.bitlbee.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE_PROTOCOLS="msn oscar purple twitter +xmpp"
-IUSE="debug +gnutls ipv6 libevent libressl nss otr +plugins selinux test xinetd
- ${IUSE_PROTOCOLS}"
-
-REQUIRED_USE="
- || ( purple xmpp msn oscar )
- xmpp? ( !nss )
-"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.16
- purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent:= )
- otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- nss? ( dev-libs/nss )
- !nss? (
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- )
- )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/logger
- xinetd? ( sys-apps/xinetd )"
-
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
-src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- eapply \
- "${FILESDIR}"/${P}-systemd-user.patch \
- "${FILESDIR}"/${P}-verbose-build.patch
- fi
-
- eapply_user
-}
-
-src_configure() {
- local myconf
-
- # setup plugins, protocol, ipv6 and debug
- myconf+=( --jabber=$(usex xmpp 1 0) )
- for flag in debug ipv6 plugins ${IUSE_PROTOCOLS/+xmpp/} ; do
- myconf+=( --${flag}=$(usex ${flag} 1 0) )
- done
-
- # set otr
- if use otr && use plugins ; then
- myconf+=( --otr=plugin )
- else
- if use otr ; then
- ewarn "OTR support has been disabled automatically because it"
- ewarn "requires the plugins USE flag."
- fi
- myconf+=( --otr=0 )
- fi
-
- # setup ssl use flags
- if use gnutls ; then
- myconf+=( --ssl=gnutls )
- einfo "Using gnutls for SSL support"
- else
- ewarn "Only gnutls is officially supported by upstream."
- if use nss ; then
- myconf+=( --ssl=nss )
- einfo "Using nss for SSL support"
- else
- myconf+=( --ssl=openssl )
- einfo "Using openssl for SSL support"
- fi
- fi
-
- # set event handler
- if use libevent ; then
- myconf+=( --events=libevent )
- else
- myconf+=( --events=glib )
- fi
-
- # not autotools-based
- ./configure \
- --prefix=/usr \
- --datadir=/usr/share/bitlbee \
- --etcdir=/etc/bitlbee \
- --plugindir=/usr/$(get_libdir)/bitlbee \
- --systemdsystemunitdir=$(systemd_get_systemunitdir) \
- --doc=1 \
- --strip=0 \
- --verbose=1 \
- "${myconf[@]}" || die
-
- sed -i \
- -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
- Makefile.settings || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" LD="$(tc-getLD)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-etc install-doc install-dev install-systemd
-
- keepdir /var/lib/bitlbee
- fperms 700 /var/lib/bitlbee
- fowners bitlbee:bitlbee /var/lib/bitlbee
-
- dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
-
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins doc/bitlbee.xinetd bitlbee
- fi
-
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
-
- exeinto /usr/share/bitlbee
- doexe utils/{convert_purple.py,bitlbee-ctl.pl}
-}
-
-pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
- fi
-}
diff --git a/net-im/bitlbee/files/bitlbee-3.2.1-configure.patch b/net-im/bitlbee/files/bitlbee-3.2.1-configure.patch
deleted file mode 100644
index 5bde108af32c..000000000000
--- a/net-im/bitlbee/files/bitlbee-3.2.1-configure.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- bitlbee-3.0.6/configure
-+++ bitlbee-3.0.6/configure
-@@ -612,14 +612,6 @@
- fi
- fi
-
--case "$CC" in
--*gcc* )
-- echo CFLAGS+=-MMD -MF .depend/\$@.d >> Makefile.settings
-- for i in . lib tests protocols protocols/*/; do
-- mkdir -p $i/.depend
-- done
--esac
--
- if [ "$msn" = 0 ]; then
- echo '#undef WITH_MSN' >> config.h
- else
diff --git a/net-im/bitlbee/files/bitlbee-3.4.2-systemd-user.patch b/net-im/bitlbee/files/bitlbee-3.4.2-systemd-user.patch
deleted file mode 100644
index 07d58f4f3318..000000000000
--- a/net-im/bitlbee/files/bitlbee-3.4.2-systemd-user.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/init/bitlbee.service.in
-+++ b/init/bitlbee.service.in
-@@ -4,6 +4,7 @@
-
- [Service]
- ExecStart=@sbindir@bitlbee -F -n
-+User=bitlbee
-
- [Install]
- WantedBy=multi-user.target