summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/vim-rest-console/Manifest1
-rw-r--r--app-vim/vim-rest-console/metadata.xml11
-rw-r--r--app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild21
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/vim-rest-console/Manifest b/app-vim/vim-rest-console/Manifest
new file mode 100644
index 000000000000..216bb2e7bf55
--- /dev/null
+++ b/app-vim/vim-rest-console/Manifest
@@ -0,0 +1 @@
+DIST vim-rest-console-2.3.0.tar.gz 11584 SHA256 e3d07527a41f03eeffc82f12e1de43865f36f7348e4bf99fc4e2af55b234a74a SHA512 04fa4cc2177b87a6d69ad50d0e45f411169d178e4990280afde730c461cb718acd09dc034e61c51f73974369d9be9300281f1e60adf8084730977caa27c65da2 WHIRLPOOL 93b5bc602361a2abe845a688b0e8c22cc7c3e3d6dd671f37e8d576f9d3c06ebaea3da58ac2838634a7219dd6fe1a56cc666d3a076e799bad1cae2636996371e9
diff --git a/app-vim/vim-rest-console/metadata.xml b/app-vim/vim-rest-console/metadata.xml
new file mode 100644
index 000000000000..2d3e3d904848
--- /dev/null
+++ b/app-vim/vim-rest-console/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">diepm/vim-rest-console</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild b/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild
new file mode 100644
index 000000000000..6c8b9acf4879
--- /dev/null
+++ b/app-vim/vim-rest-console/vim-rest-console-2.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a REST console for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=5182 https://github.com/diepm/vim-rest-console"
+SRC_URI="https://github.com/diepm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="net-misc/curl"
+
+src_prepare() {
+ rm *.md *.json *.rest || die
+}