summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/express/express-1.5.1.ebuild3
-rw-r--r--sci-biology/express/files/express-1.5.1-gcc6.patch19
2 files changed, 21 insertions, 1 deletions
diff --git a/sci-biology/express/express-1.5.1.ebuild b/sci-biology/express/express-1.5.1.ebuild
index 5a7ef2f98f0c..62e5361f529f 100644
--- a/sci-biology/express/express-1.5.1.ebuild
+++ b/sci-biology/express/express-1.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,6 +26,7 @@ S="${WORKDIR}/${P}-src"
PATCHES=(
"${FILESDIR}"/${P}-buildsystem.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_configure() {
diff --git a/sci-biology/express/files/express-1.5.1-gcc6.patch b/sci-biology/express/files/express-1.5.1-gcc6.patch
new file mode 100644
index 000000000000..8a608b97b056
--- /dev/null
+++ b/sci-biology/express/files/express-1.5.1-gcc6.patch
@@ -0,0 +1,19 @@
+Bug: https://bugs.gentoo.org/610692
+
+--- a/src/targets.cpp
++++ b/src/targets.cpp
+@@ -113,12 +113,12 @@
+
+ double ll = LOG_1;
+ double tot_mass = mass(with_pseudo);
+- double tot_eff_len = cached_effective_length(lib.bias_table);
++ double tot_eff_len = cached_effective_length(static_cast<bool>(lib.bias_table));
+ if (neighbors) {
+ foreach (const Target* neighbor, *neighbors) {
+ tot_mass = log_add(tot_mass, neighbor->mass(with_pseudo));
+ tot_eff_len = log_add(tot_eff_len,
+- neighbor->cached_effective_length(lib.bias_table));
++ neighbor->cached_effective_length(static_cast<bool>(lib.bias_table)));
+ }
+ }
+ ll += tot_mass - tot_eff_len;