summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-electronics/systemc/Manifest1
-rw-r--r--sci-electronics/systemc/systemc-2.2.0-r2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/sci-electronics/systemc/Manifest b/sci-electronics/systemc/Manifest
index 66a118fbe3da..8ee56cba530b 100644
--- a/sci-electronics/systemc/Manifest
+++ b/sci-electronics/systemc/Manifest
@@ -1,3 +1,2 @@
-DIST systemc-2.2.0.tgz 2050634 SHA256 fd7db3ac2b547bf54c94c0310f15f079ed59ffa318ed5b0043a65410960859e7 SHA512 221e411d8037bd75ce4c5ced858351dd7e24554cdf541ece35f087fae7c9905315be4ebde5210f365dba9594167affe37f267ccf10b01ddb82fa5c980b2affc7 WHIRLPOOL 85cce5a92f7c912a11bb7bdd5817f410b2ed11d85ff9d6d8c82ba42fc436bc2ad2802d7cabc2f0b8dd05800f69cc92fdd7166afbd7329cfccc709fcff3cecc02
DIST systemc-2.3.0a.tar.gz 7084178 SHA256 b9da6e78e960543eb531b7bfaf65809320f53832744ee22af4431300e81bf8c5 SHA512 3af3c0c96a95ee75e0a6c046fdd94ee822b8fbbc1c79e7bbf9b905e7a2d3689282e6d97cfa56c93094155d79126e74f052c0f0e12f31bf4321b28a03aae347ab WHIRLPOOL b5b3fe7ab3dcf523e5b26177a787649b2793002544cf35c97aec34d1fcc9e5481f47ec8c031cb1a7ad4390876c549e2145283a31551129bde2aecb9a66209fee
DIST systemc-2.3.1a.tar.gz 7050669 SHA256 3e9d0afb5b76f5435305c2f0481b203041373d4a24776c301204c87b3e0f5c81 SHA512 cd52eb6e413c8b852e19c8387766eacbddf85e9b2f4d137f3d82d0d4025f13a44216a2e6cacf7b9e2b972584912a4a1c75cdb37a568330ce66a6bf909ca1b723 WHIRLPOOL 678b655dcf63c0d201a7be3827775baa4a79761411a5643a4132842e576fc92502b166ff876c97a546c2ed78503b2ecb4fc2319b8b651dfcc3437dd9baae26f8
diff --git a/sci-electronics/systemc/systemc-2.2.0-r2.ebuild b/sci-electronics/systemc/systemc-2.2.0-r2.ebuild
deleted file mode 100644
index a07ac3aaea88..000000000000
--- a/sci-electronics/systemc/systemc-2.2.0-r2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit versionator multilib toolchain-funcs
-
-DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
-HOMEPAGE="http://www.systemc.org/"
-SRC_URI="${P}.tgz"
-
-SLOT="0"
-LICENSE="SOPLA-2.3"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-RESTRICT="fetch test"
-
-pkg_nofetch() {
- elog "${PN} developers require end-users to accept their license agreement"
- elog "by registering on their Web site (${HOMEPAGE})."
- elog "Please download ${A} manually and place it in ${DISTDIR}."
-}
-
-src_prepare() {
- sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.in) || die "Patching Makefile.in failed"
-
- sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"${CXXFLAGS}\":g" configure || die "Patching configure failed"
-
- sed -i -e '/#include "sysc\/utils\/sc_report.h"/a \
-#include <cstdlib> \
-#include <cstring>' src/sysc/utils/sc_utils_ids.cpp || die "Patching failed"
-
- for sfile in src/sysc/qt/md/*.s ; do
- sed -i -e '$a \
-#if defined(__linux__) && defined(__ELF__) \
-.section .note.GNU-stack,"",%progbits \
-#endif' "${sfile}" || die "Patching ${sfile} failed"
- done
-}
-
-src_configure() {
- econf --disable-dependency-tracking CXX=$(tc-getCXX)
-}
-
-src_compile() {
- cd src
- default
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
- doins -r docs
- cd src
- default
-}
-
-pkg_postinst() {
- elog "If you want to run the examples, you need to :"
- elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
- elog " cd ${P}"
- elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
- elog " ./configure"
- elog " cd examples"
- elog " make check"
-}