summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apache/mod_wsgi/Manifest1
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/Manifest b/www-apache/mod_wsgi/Manifest
index 6b4d03b7d81c..4e2845be9757 100644
--- a/www-apache/mod_wsgi/Manifest
+++ b/www-apache/mod_wsgi/Manifest
@@ -1,3 +1,4 @@
DIST mod_wsgi-4.5.13.tar.gz 679121 BLAKE2B 310a6a56495883439fad4a5ee7b30e749aaec4131bc039fd378018c30c9b61f1cb2c8b0ed6339c4a9cf556571e2713ff356b04007f1e2a10bcac52ddd5e5d14f SHA512 94bf6ae0d76ece67682a8ca3b7f202bb08a1f3e09e42c33f52b561a57ac8265ca2f5431f839bfe731eb014f279b0d865fd007f14a4839c934d372390d24a44a2
DIST mod_wsgi-4.5.17.tar.gz 680160 BLAKE2B 496f81cea9256622bc6ee96308b47c264479701f64bcd5bef7699211a288a45d459df8f30b014cdf1e9b911b6aeff454ca7ccb5cb8eebe8b238e903a89fd8a26 SHA512 d40fb48b654bd49d36c4a249527c9190eb7aea2bd138c035ae304a48cb6e223aa34831a2eeec8aade9ac3bafe2493f35a2359caca1e8ec9dd6aff013693de973
DIST mod_wsgi-4.5.21.tar.gz 682330 BLAKE2B 984437becb86e1df5bb3fcdb55c441d9634c98181f3704068617773f61048ccd38ea8617409b6e64413fb3584eaf46bd2c8fe67afd86993e4e0e85076d2bd98a SHA512 3180cf19bd5238586b288a030542c779533da8a35531f5d18edd85a1143e515b0906a599d2e1fd3251e3fa19bde6469fdc5c92850d9544e115736262c083d383
+DIST mod_wsgi-4.6.5.tar.gz 693825 BLAKE2B 1564c331505706548ed171a6f57ad8947eea257295ecae56c0d3e87c4d15743ea4bb0275ae94a6168912ff27fcfcd06eec823b8332d19895ed803ad6164da77b SHA512 5f1526b74ea59c8ef897b49b1b2f2de42d9d0144277fd74f9f8e1f3e0198735f98ec30f726883a3192d0ed33a4013232cb2adf8db9d817b4de0198890eaa7044
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild
new file mode 100644
index 000000000000..959f38d461bb
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
+}
+
+src_compile() {
+ default
+}