summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.0.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
index 8dc97acfe007..c494bc22f847 100644
--- a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
@@ -25,8 +25,6 @@ KEYWORDS="~amd64"
# Ditto
# - tests/commands/install_uninstall_test.py::test_installed_from_venv
# "git commit" returns 1 instead of 0, again no details
-# even with the environment variables normally handled by pytest-env (which we haven't got in the tree yet)
-# explicitly declared in python_test().
#RESTRICT="test"
RDEPEND="dev-vcs/git
@@ -39,7 +37,10 @@ RDEPEND="dev-vcs/git
>=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
')"
BDEPEND="test? (
- $(python_gen_cond_dep 'dev-python/re-assert[${PYTHON_USEDEP}]')
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
)"
DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
@@ -53,15 +54,3 @@ src_prepare() {
# and while some of them do include "skip if not found" logic, most of them do not.
rm -rf tests/languages tests/repository_test.py
}
-
-python_test() {
- # TODO: add pytest-env to the tree so that these can be read from tox.ini
- declare -x GIT_AUTHOR_NAME=test
- declare -x GIT_COMMITTER_NAME=test
- declare -x GIT_AUTHOR_EMAIL=test@example.com
- declare -x GIT_COMMITTER_EMAIL=test@example.com
- declare -x VIRTUALENV_NO_DOWNLOAD=1
- declare -x PRE_COMMIT_NO_CONCURRENCY=1
-
- distutils-r1_python_test
-}