summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.48.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 3806ebbee88c..3424cb0af5b1 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,3 +1,4 @@
DIST lilypond-2.18.2.tar.gz 16027977 SHA256 329d733765b0ba7be1878ae3f457dbbb875cc2840d2b75af4afc48c9454fba07 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6 WHIRLPOOL 95db264992a1e425fd1ee53d980941eef554c1784a1adfc105750d82d11664f61207c2b1897b6e99448790131c0715f08401f45b663c420553925596c6fd4b1c
DIST lilypond-2.19.46.tar.gz 16899476 SHA256 f609051e2128c40da17698c0432fe8a96858583d197a8264fc4bceeab0378674 SHA512 594921b784f6604bfb2210569fac03911cb5c4c11e2e9241f62153d7c012b5e10cd2cacd3ac3d69c1719c9b6fddc550d381a9fa9b96f22ada63019b38ef95de1 WHIRLPOOL b77b1bc76ccdf6e17179fd9b1497beac96da2bd1ce83b7944a2a8f4a5d6274581c8e7f4c9e2de44b53912df702731456cd2658d96cccb186347f1a4577146a4d
DIST lilypond-2.19.47.tar.gz 16926783 SHA256 842312813a9144b6b54a33f13fb19addbfc779d7bbfe3b2075be1235287de08c SHA512 8720a11f0410bd462db1bf11508a7181953b099918b01fc3707a52a2269a840473fc22065b82fad59d98fdd84e54d3810c2c6a4302754d36f1bd6d847e7f72bd WHIRLPOOL ccd8eee71067b0811a32a0ad6572031f936e95637266909534a5212783f0c0fe99eac7406aadae21b17e632c3fb1f1c50b945d4d0e9b64b32ec1c976bf8406c1
+DIST lilypond-2.19.48.tar.gz 16928689 SHA256 84b586cfe933a330e964b1c3e95c41525499eca6a5625089044d943e9cc768c8 SHA512 aa128a651af69579ef7fead0a88b57697c2a4a2604f9e81232b48d6b355a0f6e1f372b12454f7154126c78516341a7123bba8aa2dcd4eb17c819030e51a893f9 WHIRLPOOL 5f8d31a93355ec9c0871bec73d0e9ed8ac57989a3e0d8d40df3953c1439ad986529a1f7665025c4e68473f4d87805f17c1a42ef8fa8bb604c8ff21871e65f14a
diff --git a/media-sound/lilypond/lilypond-2.19.48.ebuild b/media-sound/lilypond/lilypond-2.19.48.ebuild
new file mode 100644
index 000000000000..63535e73399f
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.19.48.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1
+
+if [[ "${PV}" = "9999" ]]; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+ SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ virtual/pkgconfig
+ media-gfx/fontforge[png]
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+ # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+ if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+ if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+ einfo "Updating metapost symlink"
+ eselect mpost update || die
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ # respect AR
+ sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable profile profiling)
+ )
+
+ has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}