summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hgtools/Manifest1
-rw-r--r--dev-python/hgtools/hgtools-6.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/hgtools/Manifest b/dev-python/hgtools/Manifest
index 2ac2f62165fc..b0b9645b9312 100644
--- a/dev-python/hgtools/Manifest
+++ b/dev-python/hgtools/Manifest
@@ -1,2 +1,3 @@
DIST hgtools-6.0.zip 37542 SHA256 14f3f4d94827c2d45e5a05ffd6efbe2484f662354a3dce2d8d1a29df1b05dd5a SHA512 86443caa03ff5c8fe3b2f5d503c8d28ddc8e29f4818fb7d3b51233b79eb4977c98bd83ccdba0612c3c17ecddacd6d7c7b283dc6ffc935eeb7a5b1a099324e9af WHIRLPOOL d8517f2b6a769201246a5072c971880b4ae52cdfc8aec2f619cd642337eb3cfdf5abee06aa91792a8380c0d81f9a68949a9efa3f44a29a3218b8d9bea8601802
DIST hgtools-6.3.zip 39805 SHA256 1d0ef6ceaba1673e6923b17d7f09c5ae2f4394d16ef80562812987a27e7836ff SHA512 b5654194f6fbaf37c2a63523b02371ca6af1d7b7f7a89938ba4e405076049a054fff5e6d0d4a8b53560cde7dfc4a1862c5359d710d91c208dd83611913f17a7f WHIRLPOOL efe5bca6ce0970f0199b5c757dd8fd0bd4a03ad64f4ef571e4dbae311afd22c753aa6831fc688718cbc8ef037700a3b81220dae318f82a0ea9fe4d4179cfe4e3
+DIST hgtools-6.5.1.tar.gz 22389 SHA256 638a29345707569944459b063763a00c2a3651bc489b1e0dfe0d1d6f3c3c518f SHA512 7a9cd405f4e3f49c57b89e85bca1dff6bfcce91c86a1f006f4223c23a82b13b57468c583815719b9c7e6189070381cf9345c3b7b06d9ed83cf1ed6994293c130 WHIRLPOOL 53f56ab71dca4ed824f84670b9f93e68b827453bb99075f4e2af684ef121fe27d011409819b604d233ea6660f4194c6807d2133f7f819da6d74a732952d322f4
diff --git a/dev-python/hgtools/hgtools-6.5.1.ebuild b/dev-python/hgtools/hgtools-6.5.1.ebuild
new file mode 100644
index 000000000000..46a3c5859554
--- /dev/null
+++ b/dev-python/hgtools/hgtools-6.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+RESTRICT="test"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Classes and setuptools plugin for Mercurial repositories"
+HOMEPAGE="https://bitbucket.org/jaraco/hgtools/"
+SRC_URI="mirror://pypi/h/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-vcs/mercurial"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ py.test "${PN}"/tests || die
+ popd > /dev/null
+}