summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-3.2.1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index bc875d3552e3..a247e59b85d7 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -4,4 +4,5 @@ DIST pymongo-2.8.1.tar.gz 399521 SHA256 300ea5762d059c07d1bb2578f35bd0e55bc31753
DIST pymongo-2.9.tar.gz 430741 SHA256 90e994cfe5928841960dabdca709e75ab4d0f44b288fd59742113982d96290c4 SHA512 c12701797643b41503829b6c7e573cfff7d8c63c56d9eb195f1a67dc3204cd7ed2a28ee2bd2ce34d0c68bade3f44c8bd5c069b15082bf3388c3a401a35424b1e WHIRLPOOL 699a7f658734837f40fe4190251f8e8bb69dba80bbc6dba60207bb18d5dfb43ec5d1c6aca8810b45e7914705305416d0f76face88fd0c43aa20c6d0765eff01c
DIST pymongo-3.0.3.tar.gz 419692 SHA256 3c6b2317f8031bc1e200fd1ea35f00a96f4569e3f3f220a5e66ab6227d96ccaf SHA512 7a20fdcae5b3f852bded19c95b36ef6a8141bce0179440a2c5966cbb9f18f3985b7b6b4584c5253c34d0f846d809d72ec0ae076c88472a3de6f090466e9132b4 WHIRLPOOL ae610909b610c7d116dd3aa7c04ab9ce357b25208b07c025924c53bb36183a6d344ecff214def6a01b929dc50d698464c8dd33b6eafd2d88d6666d8534858a38
DIST pymongo-3.1.tar.gz 462030 SHA256 fe7033007100f825a67640e77abdafee28713f255da88fcfc8d6abad0bb34285 SHA512 886cfbffd4514741e92ad1c79e97ee443d5c9874c823b64c3c2f2566e3005d588d7dd4ae813c320c94f3e6e12b1dd8c7ad56f0e6d2ee419f0d66f4c38321c9ab WHIRLPOOL ec39a42738b751875b92ca8501ccc1711f8e474efef8cf2817525dc47e420e03b7a581d9e35e4f94f529e07a7d81499f7d6e9402c085d9e47861c8a691d1e37e
+DIST pymongo-3.2.1.tar.gz 647879 SHA256 57a86ca602b0a4d2da1f9f3afa8c59fd8ca62d829f6d8f467eae0b7cb22ba88a SHA512 c4dc677c4df5cddde003d253692ba80d82443000c0841dc6a15420823ec1f98a3b1b8da2ee5ac9ca65fcbfd8144d886d555c32b68efc7737c19ed8412c12bcc7 WHIRLPOOL 6c7b92383245ef5c454cb19ad85e0160db9d0d3ebd9e4b9e5120178ceb5fcf89068f6e95cc52989a26fbd22e15ad6150d7db65bf5a63b040991e6d081a8a4c3c
DIST pymongo-3.2.tar.gz 473631 SHA256 f50a5380b45a83c5ea1e673ff19363d3cfd5850f7620536e51341d26eb2ae979 SHA512 e0962729bada4ee03cafebac4cd8a0da8abd2e1ef75672897b974e6752acbee247007c8bc5344a28b04b09bcd87c1cbef82e5e71e1b4fdd9074fc3bf56000d2c WHIRLPOOL b4e4ce729c0033071cb99436fd4d380e4818e4bd056c73aa1f2d8e6151ba03152db7426eeb7e9e8af94d6d7e7de63889201e0240cab3ec9b52e0690b3d1eea7c
diff --git a/dev-python/pymongo/pymongo-3.2.1.ebuild b/dev-python/pymongo/pymongo-3.2.1.ebuild
new file mode 100644
index 000000000000..8fbd7cd7b6bc
--- /dev/null
+++ b/dev-python/pymongo/pymongo-3.2.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.python.org/pypi/pymongo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc kerberos test"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-db/mongodb-2.6.0
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir html || die
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --smallfiles --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ if [[ "${EPYTHON}" == python3* ]]; then
+ 2to3 --no-diffs -w test
+ fi
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}