summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/ptex/Manifest1
-rw-r--r--media-libs/ptex/metadata.xml19
-rw-r--r--media-libs/ptex/ptex-2.1.28.ebuild23
3 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/ptex/Manifest b/media-libs/ptex/Manifest
new file mode 100644
index 000000000000..a9e65e006a85
--- /dev/null
+++ b/media-libs/ptex/Manifest
@@ -0,0 +1 @@
+DIST ptex-2.1.28.tar.gz 305327 SHA256 919af3cc56a7617079757bac5c0202f4375acf21861a3990e313739e56a6142c SHA512 ddce3c79f14d196e550c1e8a5b371482f88190cd667a2e2aa84601de1639f7cabb8571c1b3a49b48df46ce550d27088a00a67b1403c3bfec2ed73437c3dca3e8 WHIRLPOOL 996faad06ce8f016d24c8ec82e4422eab0e576976184bb27c24a3843eede53a3a2db5a6f572148c55bed3c6953dcdba30fa5d38e82fc1ea76e907bb5730fe5c7
diff --git a/media-libs/ptex/metadata.xml b/media-libs/ptex/metadata.xml
new file mode 100644
index 000000000000..b59312f7b717
--- /dev/null
+++ b/media-libs/ptex/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer restrict="&gt;=media-libs/ptex-2.1.10" type="person">
+ <email>j.scruggs@gmail.com</email>
+ <name>Jonathan Scruggs</name>
+ </maintainer>
+ <maintainer restrict="&gt;=media-libs/ptex-2.1.10" type="person">
+ <email>agrigo2001@yahoo.com.au</email>
+ <name>Adrian Grigo</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Per-Face Texture Mapping for Production Rendering.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-libs/ptex/ptex-2.1.28.ebuild b/media-libs/ptex/ptex-2.1.28.ebuild
new file mode 100644
index 000000000000..adefaa471fe5
--- /dev/null
+++ b/media-libs/ptex/ptex-2.1.28.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="http://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html )
+ cmake-utils_src_configure
+}