summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r1.ebuild b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r1.ebuild
index e195c9658202..9600e6cfeb20 100644
--- a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r1.ebuild
+++ b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="Configurable Tray Icons for GKrellM"
@@ -13,11 +14,12 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-RDEPEND="app-admin/gkrellm[X]"
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
-PLUGIN_SO=trayicons.so
+PLUGIN_SO=( trayicons$(get_modname) )
src_compile() {
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"