summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/openipmi/Manifest1
-rw-r--r--sys-libs/openipmi/files/openipmi-2.0.21-tinfo.patch18
-rw-r--r--sys-libs/openipmi/openipmi-2.0.21.ebuild105
3 files changed, 124 insertions, 0 deletions
diff --git a/sys-libs/openipmi/Manifest b/sys-libs/openipmi/Manifest
index 52e36af2e49c..87bb6b0ec407 100644
--- a/sys-libs/openipmi/Manifest
+++ b/sys-libs/openipmi/Manifest
@@ -5,3 +5,4 @@ DIST OpenIPMI-1.4.28.tar.gz 2310138 SHA256 75fbff6c03c1bbea448aa8021aa2f0ee5c4f7
DIST OpenIPMI-2.0.11.tar.gz 2897970 SHA256 9a824bc1faf69ef8e668dcc426c356b41abb4a18a7367c9fbbc87350df7b9cfa SHA512 266c380b83a445fd6cec5be73c8235f69229df61bf644e25d2a99dbc371e2adb66ee93c07972aa904a80f1be627d13ca2817f2815db3bb05c34e3418cd8b7392 WHIRLPOOL d9d46a8b275c25f7b6855728884189ed7ae36f03690ccc702cff32881d8a9ab481815d4105243917a4230390a4c8fd8e0181c0c8d70b800e958baad1936f4f7f
DIST OpenIPMI-2.0.16.tar.gz 2890960 SHA256 1a2f9881f27de2bb64b70c8bf9a7c38b5447e4c9a0ec9e0bf6a2833f15893c05 SHA512 f848f805427c886f41419d1312b4b2103bccf99a395c445abf4753809a5a4780a9105d25684527d4d9f43b8047726d273d18708ac67b99bae18fc294b5ea37a9 WHIRLPOOL e070a383a0639742a6302a3e546ed1a26c4a491561daf2ef991049892f4de0659370c993c486a9c2217549cf18e9829cb6fe4497b9cc528f222c0a16d612d88a
DIST OpenIPMI-2.0.18.tar.gz 2895686 SHA256 6c1679a1c16aade48dd929e5124d2640ff12224ac0de1bb3777e9f1030d62e01 SHA512 a6caf791fb6d5bd83234481ea3c84a408dad3eabc093dbc4681742d23b47b223d0a1715a71a9b977a03a80f5c350dd34f6591ece5ea0d9876cb6debfc80a39d4 WHIRLPOOL 3b9bd32e01c118a450c5f6ec744b5cad521d41091f786a59485b91cde05ca184bdb4d8c05d53e9494966a9a733c560190f85208bedaa3b40e2cac116e3e6a84a
+DIST OpenIPMI-2.0.21.tar.gz 3473323 SHA256 37b844d02119b94b31e2bb2bd8062ffdf6cd3eb4bc75fa6c47184e8b14fe95b8 SHA512 b684259ee5d47c36273fe6b47d60d0481c96b64b2e9421ce3190d9514e4f450b0db28d12c86a8814dcce23ba3ecfcecbbe9251d298244f1e9194a9f7563862a5 WHIRLPOOL 577da7215effe5f2e26616b4c744da42fd261263834d4d3d264220f95c4a60b3955c642d27c32af30dbf2ce0821078a463fa140edc9d3475daec7e6f84361958
diff --git a/sys-libs/openipmi/files/openipmi-2.0.21-tinfo.patch b/sys-libs/openipmi/files/openipmi-2.0.21-tinfo.patch
new file mode 100644
index 000000000000..5eb8642ab2e4
--- /dev/null
+++ b/sys-libs/openipmi/files/openipmi-2.0.21-tinfo.patch
@@ -0,0 +1,18 @@
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2014-01-28 20:35:02.000000000 +0100
++++ b/configure.ac 2015-09-23 17:05:03.526010122 +0200
+@@ -861,10 +861,12 @@
+ *-sun-*) AC_DEFINE([_SUNOS], [], [Solaris's term.h does horrid things.]);;
+ esac
+
+-AC_CHECK_LIB(curses, tgetent, TERM_LIBS=-lcurses,
++PKG_CHECK_MODULES(ncurses, ncurses, TERM_LIBS=$ncurses_LIBS,
++ [AC_CHECK_LIB(tinfo, tgetent, TERM_LIBS=-ltinfo,
++ [AC_CHECK_LIB(curses, tgetent, TERM_LIBS=-lcurses,
+ [AC_CHECK_LIB(ncursesw, tgetent, TERM_LIBS=-lncursesw,
+ [AC_CHECK_LIB(ncurses, tgetent, TERM_LIBS=-lncurses,
+- [AC_MSG_ERROR([libtermcap, libcurses or libncurses are required!])])] )] )
++ [AC_MSG_ERROR([libtinfo, libtermcap, libcurses or libncurses are required!])])] )] )] )] )
+
+ # Checks for header files.
+ AC_FUNC_ALLOCA
diff --git a/sys-libs/openipmi/openipmi-2.0.21.ebuild b/sys-libs/openipmi/openipmi-2.0.21.ebuild
new file mode 100644
index 000000000000..0f6bcbf76cda
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-2.0.21.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools python-single-r1
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl python tcl"
+S="${WORKDIR}/${MY_P}"
+RESTRICT='test'
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/gdbm
+ crypt? ( dev-libs/openssl:0= )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.21
+ virtual/pkgconfig"
+# Gui is broken!
+# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ # Bug #338499: The installed OpenIPMIpthread.pc depends on a non-existing
+ # pthread.pc. We patch it to link -lpthread directly instead.
+ "${FILESDIR}/${PN}-2.0.16-pthreads.patch"
+
+ # https://bugs.gentoo.org/501510
+ "${FILESDIR}/${PN}-2.0.21-tinfo.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Bug #290763: The buildsys tries to compile+optimize the py file during
+ # install, when the .so might not be been added yet. We just skip the files
+ # and use python_optimize ourselves later instead.
+ sed -r -i \
+ -e '/INSTALL.*\.py[oc] /d' \
+ -e '/install-exec-local/s,OpenIPMI.pyc OpenIPMI.pyo,,g' \
+ swig/python/Makefile.{am,in}
+
+ # Bug #298250: parallel install fix.
+ sed -r -i \
+ -e '/^install-data-local:/s,$, install-exec-am,g' \
+ cmdlang/Makefile.{am,in}
+
+ # We touch the .in and .am above because if we use the below, the Perl stuff
+ # is very fragile, and often fails to link.
+ #cd "${S}"
+ elibtoolize
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ myconf+=( $(use_with snmp ucdsnmp yes) )
+ myconf+=( $(use_with crypt openssl yes) )
+ myconf+=( $(use_with perl perl yes) )
+ myconf+=( $(use_with tcl tcl yes) )
+ myconf+=( $(use_with python python yes) )
+
+ # GUI is broken
+ #use tk && use python && use !tcl && \
+ # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+ #if use python && use tcl; then
+ # myconf+=( $(use_with tk tkinter) )
+ #else
+ # myconf+=( --without-tkinter )
+ #fi
+
+ myconf+=( --without-tkinter )
+ myconf+=( --with-glib --with-swig )
+ # these binaries are for root!
+ econf ${myconf[@]} --bindir=/usr/sbin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
+ newdoc cmdlang/README README.cmdlang
+
+ use python && python_optimize
+}