summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.mask6
-rw-r--r--virtual/wireguard/metadata.xml12
-rw-r--r--virtual/wireguard/wireguard-1.ebuild29
3 files changed, 0 insertions, 47 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index c1d2e8dfed3..d35f1b756a8 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -306,12 +306,6 @@ dev-python/distributed
# Removal in 30 days.
dev-tex/herm-pic
-# Jason A. Donenfeld <zx2c4@gentoo.org> (2020-07-31)
-# This package has been deprecated for 8 months now, in addition to
-# loud ewarns upon every install. It is replaced with explicitly
-# installing net-vpn/wireguard-tools. Removal in 7 days.
-virtual/wireguard
-
# Michał Górny <mgorny@gentoo.org> (2020-07-28)
# Masked for the time being due to dep on LLVM 8. Bug #720236.
<=dev-ada/gps-2019-r1
diff --git a/virtual/wireguard/metadata.xml b/virtual/wireguard/metadata.xml
deleted file mode 100644
index a2b169f1920..00000000000
--- a/virtual/wireguard/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zx2c4@gentoo.org</email>
- <name>Jason A. Donenfeld</name>
- </maintainer>
- <use>
- <flag name="tools">Compile the wg(8) tool and related helpers. You probably want this enabled.</flag>
- <flag name="module">Compile the actual WireGuard kernel module. Most certainly you want this enabled, unless you're doing something strange.</flag>
- </use>
-</pkgmetadata>
diff --git a/virtual/wireguard/wireguard-1.ebuild b/virtual/wireguard/wireguard-1.ebuild
deleted file mode 100644
index d203b7a7428..00000000000
--- a/virtual/wireguard/wireguard-1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="+module +tools"
-
-RDEPEND="
- tools? ( net-vpn/wireguard-tools )
- module? ( net-vpn/wireguard-modules )
-"
-
-pkg_postinst() {
- ewarn
- ewarn "This package, ${CATEGORY}/${PN}, has been deprecated, in favor of explicitly"
- ewarn "merging the tools and the modules separately. You may accomplish this by"
- ewarn "running:"
- ewarn
- ewarn " emerge -nO net-vpn/wireguard-tools net-vpn/wireguard-modules"
- ewarn " emerge -C virtual/wireguard"
- ewarn
- ewarn "When Linux 5.6 comes out, net-vpn/wireguard-modules itself will be deprecated,"
- ewarn "with its functionality having moved directly into Linux."
- ewarn
-}