summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-3.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 558722a3eb40..c1e8f7b61505 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-python-3.2.0.tar.gz 174713 SHA256 ac85dd8dec332f308e5e0e40889be0d2f10b5d6917f00f0c474405ad25dc003d SHA512 d13cb0fb46844cab512931fbb85225bdd99c44eba0761caaeb13a40f8bf18700d5836f4e24300370810ee103b4f391699db13ae0523e5625a566a9c5b41d12d5 WHIRLPOOL 9c7d1dd4a92da276f5368b80d31c11032ae0ce2ea337e21f830d433d5e7ec90759484720264a3c494f4881c8b10ce11dfbf20da0c5b89f75c0bff61cc508a065
DIST libvirt-python-3.3.0.tar.gz 179552 SHA256 e0bb7dcb98bef4933bb9d5e6e944388cdb002515eb9053a42447e89e4642fe57 SHA512 3d90e99abe813f2ba684c24631d8e8cd6a5b44564351ae3f0b75d426f80d046c00ed6358273b68ad751707a93666564dfecfb7fb7d93d2c27c71a344542fe793 WHIRLPOOL dab0e88aecc007f41505d20bc9886b9508cab7d19211f426cad7e2c65da720b4a236acbd3acd77bb35d7e3a98431764f5722035cc2f62c813864a76d42b8b73e
+DIST libvirt-python-3.4.0.tar.gz 181574 SHA256 afa77781f518988f164dd5f99d1844034ca807a8e731e07cbae18474d250b511 SHA512 96b7f16d0f7c72f2b80fda73b18e0af9b05f0fb7f7fbd4900a77808484b7f45932c8c46bde322f01486fdc97eae3e4a4906ce8555ea9a19548f9c8de46958a78 WHIRLPOOL 0bf7b220222ebcfa7d7269c53a3f9fc1db9d2b9a59d2d333484b8c906a921b28203f54a3044150562ec8a118d0f32fd3d646d62c5f53c19ee2d498f3a3912ab2
diff --git a/dev-python/libvirt-python/libvirt-python-3.4.0.ebuild b/dev-python/libvirt-python/libvirt-python-3.4.0.ebuild
new file mode 100644
index 000000000000..f93eb35e154c
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-3.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}