summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest1
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
index 55a483adccf5..532579cc848f 100644
--- a/dev-python/sphinxcontrib-httpdomain/Manifest
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -3,3 +3,4 @@ DIST sphinxcontrib-httpdomain-1.1.9.tar.gz 9589 SHA256 560eec7b60872cb570dd6a4f2
DIST sphinxcontrib-httpdomain-1.2.0.tar.gz 10054 SHA256 015e2e4327278a5903a4c060a19bfae821df2d33179c960a301c5383523a4c62 SHA512 d8c2158c81e0b0691c99176dc50d217e69b564d55e72e2878847e032dc60a4097d767bfb717f2425c2e5d37f9462cb95e15b1072b6dbb5191b9f402bc4981fe1 WHIRLPOOL 0c2482047b038f0a14b4b999ce3d24e932d3e7372af17a65fd1bb3a977acaf5a265e5df649eb06765919191181145e6bea69d03cf6b6f4b94fb5364d281b1c1a
DIST sphinxcontrib-httpdomain-1.2.1.tar.gz 10061 SHA256 68b7cca5910309dcf89b1d7fc978f2bb64c7b7e45e5b67438defed7356d96562 SHA512 0e6605e12312468ebd8d8173ac58e6ceae8823d06c9db13ee6857c9e436f8ddb14241304f1c0632cf15e616eab574107b00c79da9179e530aec099b573ad581e WHIRLPOOL a9f6d8c1a6bda6b97204855fc9809ce3658811dec981b2f7e0c3cb1e95c5a24d83ceca72374a0caa699646fee6a041da2ea77e14a075f8fc52aef0b5fb1971f9
DIST sphinxcontrib-httpdomain-1.3.0.tar.gz 11486 SHA256 ba8fbe82eddc96cfa9d7b975b0422801a14ace9d7e051b8b2c725b92ea6137b5 SHA512 2f6df6375337d651f4ed26c2aaf20929a4b31fae881ebc68fcab5cd085f52661c00a943872a9e7199d5af893b3f77434346fd493925cd148681da048aead20af WHIRLPOOL 52539d525114a2fc1b0f288cea82918724d7c4ad7af22c27efda3dcdae10ba9f800933ea163f840b12bc78413f06f0ca9bec361e0fb2da8c9430f413b1f89f7a
+DIST sphinxcontrib-httpdomain-1.4.0.tar.gz 12192 SHA256 9db07b047b8799378ae532d6b9b17080035da8d889082ad7f124de0469feeea4 SHA512 85d4d0898a1703a1742755814200253b875795b5f267b08adb00c7d8d7c15c434718ce0f93656e7b698df89c958a9f6f3f3403bdc6d08f6df322fd80371f1d70 WHIRLPOOL 1365183bd1ba9edff7c82c5c509c6d1f4fe36a35a7f88c168755d330217e4bd70600679d8a501fbacc7730901196ae62c2f6487ded513b8efed1a0012d93a1a8
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
new file mode 100644
index 000000000000..9b26fffb3fea
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib/ \
+ http://packages.python.org/sphinxcontrib-httpdomain/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"