summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.2.ebuild23
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch5
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch15
3 files changed, 22 insertions, 21 deletions
diff --git a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
index c50dd20f0339..6b8964a76be9 100644
--- a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
+++ b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils
+inherit toolchain-funcs
DESCRIPTION="Geno's cross platform benchmarking suite"
HOMEPAGE="http://bashmark.coders-net.de"
-
SRC_URI="http://bashmark.coders-net.de/download/src/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-gcc47.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+)
+
+src_configure() {
+ tc-export CXX
+
+ default
}
src_install() {
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch
index 6c01fd934e5d..7af9843a9bcc 100644
--- a/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-as-needed.patch
@@ -1,6 +1,5 @@
-diff -ru bashmark-0.6.2-orig/makefile bashmark-0.6.2/makefile
---- bashmark-0.6.2-orig/makefile 2007-10-08 23:01:06.000000000 +0300
-+++ bashmark-0.6.2/makefile 2007-10-08 23:01:22.000000000 +0300
+--- a/makefile
++++ b/makefile
@@ -10,7 +10,7 @@
BIN = bashmark
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
index 625abdab397b..02bded6c4765 100644
--- a/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
@@ -1,6 +1,5 @@
-diff -NrU5 bashmark-0.6.2.orig/Benchmark.cpp bashmark-0.6.2/Benchmark.cpp
---- bashmark-0.6.2.orig/Benchmark.cpp 2008-06-29 11:53:07.000000000 +0200
-+++ bashmark-0.6.2/Benchmark.cpp 2008-06-29 11:54:02.000000000 +0200
+--- a/Benchmark.cpp
++++ b/Benchmark.cpp
@@ -15,11 +15,11 @@
* *
* You should have received a copy of the GNU General Public License *
@@ -14,9 +13,8 @@ diff -NrU5 bashmark-0.6.2.orig/Benchmark.cpp bashmark-0.6.2/Benchmark.cpp
#include "Main.hpp"
-diff -NrU5 bashmark-0.6.2.orig/main.cpp bashmark-0.6.2/main.cpp
---- bashmark-0.6.2.orig/main.cpp 2008-06-29 11:53:07.000000000 +0200
-+++ bashmark-0.6.2/main.cpp 2008-06-29 11:56:40.000000000 +0200
+--- a/main.cpp
++++ b/main.cpp
@@ -17,10 +17,11 @@
* along with this software; if not, write to the Free Software *
* Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
@@ -29,9 +27,8 @@ diff -NrU5 bashmark-0.6.2.orig/main.cpp bashmark-0.6.2/main.cpp
#include "Output.hpp"
#include "Sysinfo.hpp"
-diff -NrU5 bashmark-0.6.2.orig/Sysinfo.cpp bashmark-0.6.2/Sysinfo.cpp
---- bashmark-0.6.2.orig/Sysinfo.cpp 2008-06-29 11:53:07.000000000 +0200
-+++ bashmark-0.6.2/Sysinfo.cpp 2008-06-29 11:55:58.000000000 +0200
+--- a/Sysinfo.cpp
++++ b/Sysinfo.cpp
@@ -15,11 +15,12 @@
* *
* You should have received a copy of the GNU General Public License *