summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 41c5db1a1edc..9562ce119b67 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -3,3 +3,4 @@ DIST ocaml-ctypes-0.6.2.tar.gz 179953 SHA256 f31671c6515b9f9df245ec08e8ac6842cf3
DIST ocaml-ctypes-0.7.0.tar.gz 181164 SHA256 8a68597b8545b36d7ced83a3365767ad0ebae99382ca7c8fff2a97666a78f94c SHA512 78929d4d9dd47e08751231a649f74259973333ecae84e6152b0a3e16a78da6b8b95bd8f69842b3b052324ecf96457eaa2b894557888aa53271917f9135259353 WHIRLPOOL 4edab9bacbea2f01676f0adc8b7058acd6097808c9d53e6d47320341de127634a3c0db3cdfd54678fdc97cb1bae8400ae79f8c5f5d55a921a3555d4f7c4ddc3a
DIST ocaml-ctypes-0.8.0.tar.gz 182704 SHA256 db465ec1bc5c0222b2fe167065d35d588cdfaf8910bcf51e0a444d528c24b32a SHA512 6478a63643fbf56391e0ab982f535afc55a79af6723a04420b156d0e5da891eff3233259083d37a35f4a15242b291bd11f5d08608fa5a9f95e6faaf434b04e68 WHIRLPOOL 0fffc7c4994c6435ac349dac176f24fcda7273db7a02f6ee2c329f98f293ac8b51aaba1a1c7d053e8527e89c6ae4d15102badc921e396139eb594f8bc8acd61d
DIST ocaml-ctypes-0.9.0.tar.gz 185021 SHA256 6a8e29447c2b24c8f4c4e5ae6f9580f42aaaa7c59ef92ed1a2944b097d87b9f3 SHA512 f94ed96b4df8b8fb11eb6d3bede7dd9d59427d3bf48357d51b32e967c3d97f6dc9f6180fa0b6e69c886a586a13ecc7ed39eff532dc499daf8117bdc1ce577410 WHIRLPOOL afc6c37bde106138cc852318f1e5db7c32cae87aee9bbe1730ad0e7e7ad1983495a1c200af3d864454eebf07fc40e8e12c0264296b1772d6a91964e507168fc9
+DIST ocaml-ctypes-0.9.1.tar.gz 185591 SHA256 66b06c312c7f3ed0363f14e0fc579650a9449e579e394ed8d26c65499614a83c SHA512 e194f21d26707ee79fb7e36df3aa5fdb76709027905a3f684fac8aafa6cd7f9a1174401646a85788ff58e31abd756d3c9ae36ee2f75adbc1f77772421aef43e6 WHIRLPOOL 5460c1680f9013f1415ee81f6e8ba7397cbd3976a10a2f492782c8b9b741573b6d5b889fbe5f5273514b104e5f8e77d62b3d536833babadd4240de8ec9164ea4
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.1.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}