summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/firefox/firefox-78.0.1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-78.0.1.ebuild b/www-client/firefox/firefox-78.0.1.ebuild
index 739b43305bf6..2fe29a4b7178 100644
--- a/www-client/firefox/firefox-78.0.1.ebuild
+++ b/www-client/firefox/firefox-78.0.1.ebuild
@@ -581,10 +581,22 @@ src_configure() {
# when they would normally be larger than 2GiB.
append-ldflags "-Wl,--compress-debug-sections=zlib"
- if use clang && ! use arm64; then
+ if use clang ; then
# https://bugzilla.mozilla.org/show_bug.cgi?id=1482204
# https://bugzilla.mozilla.org/show_bug.cgi?id=1483822
- mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
+ # moz.configure Elfhack section: target.cpu in ('arm', 'x86', 'x86_64')
+ local disable_elf_hack=
+ if use amd64 ; then
+ disable_elf_hack=yes
+ elif use x86 ; then
+ disable_elf_hack=yes
+ elif use arm ; then
+ disable_elf_hack=yes
+ fi
+
+ if [[ -n ${disable_elf_hack} ]] ; then
+ mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
+ fi
fi
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig