summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libite/files/libite-2.0.0-fix-path.patch12
-rw-r--r--dev-libs/libite/files/libite-2.0.0-fix-which-path.patch25
-rw-r--r--dev-libs/libite/libite-2.0.0.ebuild5
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libite/files/libite-2.0.0-fix-path.patch b/dev-libs/libite/files/libite-2.0.0-fix-path.patch
new file mode 100644
index 000000000000..47a3dad538b1
--- /dev/null
+++ b/dev-libs/libite/files/libite-2.0.0-fix-path.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/which.c b/tests/which.c
+index cda57c6..3e74867 100644
+--- a/tests/which.c
++++ b/tests/which.c
+@@ -21,6 +21,7 @@ int main(void)
+ { NULL, 0 }
+ };
+
++ setenv("PATH", "/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin", 1);
+ for (i = 0; test[i].cmd; i++) {
+ char *path;
+
diff --git a/dev-libs/libite/files/libite-2.0.0-fix-which-path.patch b/dev-libs/libite/files/libite-2.0.0-fix-which-path.patch
new file mode 100644
index 000000000000..301c43715890
--- /dev/null
+++ b/dev-libs/libite/files/libite-2.0.0-fix-which-path.patch
@@ -0,0 +1,25 @@
+diff --git a/tests/which.c b/tests/which.c
+index 46dcccf..cda57c6 100644
+--- a/tests/which.c
++++ b/tests/which.c
+@@ -11,13 +11,13 @@ int main(void)
+ int result = 0;
+ size_t i;
+ struct tc test[] = {
+- { "ls", 1 },
+- { "free", 1 },
+- { "modinfo", 1 },
+- { "useradd", 1 },
+- { "/bin/which", 1 },
+- { "/bin/ps aux", 1 },
+- { "/etc/passwd", 0 },
++ { "ls", 1 },
++ { "free", 1 },
++ { "modinfo", 1 },
++ { "useradd", 1 },
++ { "/usr/bin/which", 1 },
++ { "/bin/ps aux", 1 },
++ { "/etc/passwd", 0 },
+ { NULL, 0 }
+ };
+
diff --git a/dev-libs/libite/libite-2.0.0.ebuild b/dev-libs/libite/libite-2.0.0.ebuild
index 4dff1da74a46..0380b8e161c4 100644
--- a/dev-libs/libite/libite-2.0.0.ebuild
+++ b/dev-libs/libite/libite-2.0.0.ebuild
@@ -12,6 +12,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-which-path.patch
+ "${FILESDIR}"/${P}-fix-path.patch
+)
+
src_configure(){
econf --enable-static=$(usex static-libs)
}