summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jetty-npn-api/Manifest1
-rw-r--r--dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild25
-rw-r--r--dev-java/jetty-npn-api/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/jetty-npn-api/Manifest b/dev-java/jetty-npn-api/Manifest
new file mode 100644
index 000000000000..41aba6ef35e7
--- /dev/null
+++ b/dev-java/jetty-npn-api/Manifest
@@ -0,0 +1 @@
+DIST npn-api-1.1.1.v20141010-sources.jar 3078 SHA256 0d9ec6fcde094ff785522fc403576e338b29207f4266155398c91defb1a26455 SHA512 8ae7847dfae1e2f0561f976ed887eeadcf62594c88df6400a79cd5f02b877e83016ade6f93153a9c31eb2ba41ea436c1c4faa960713f72c0d2bfa818c96cc13b WHIRLPOOL db15844781896fdf93e54fc6db302fb20c48e171367e2132dfba82e41301e8a665b78f270a5ee6626f2c98ef257caa7b120cf7c377f799b2f7105fb4183b63a7
diff --git a/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild b/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild
new file mode 100644
index 000000000000..56ece4d9a05e
--- /dev/null
+++ b/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/jetty-/}"
+MY_PV="${PV}.v20141010"
+MY_P="${MY_PN}-${MY_PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jetty's NPN API"
+HOMEPAGE="http://www.eclipse.org/jetty/"
+SRC_URI="http://central.maven.org/maven2/org/eclipse/jetty/npn/${MY_PN}/${MY_PV}/${MY_P}-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip"
diff --git a/dev-java/jetty-npn-api/metadata.xml b/dev-java/jetty-npn-api/metadata.xml
new file mode 100644
index 000000000000..6aaf1c0d7d08
--- /dev/null
+++ b/dev-java/jetty-npn-api/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>The Jetty project provides an implementation of the Next Protocol Negotiation TLS Extension (NPN) for OpenJDK 7 or greater. NPN allows the application layer to negotiate which protocol to use over the secure connection.
+
+NPN currently negotiates using SPDY as an application level protocol on port 443, and also negotiates the SPDY version. However, NPN is not SPDY specific in any way. Jetty's NPN implementation, although hosted under the umbrella of the Jetty project, is independent of Jetty (the servlet container); you can use it in any other Java network server.</longdescription>
+</pkgmetadata>