summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/gentoo-setup16
-rw-r--r--app-admin/webmin/webmin-1.770.ebuild (renamed from app-admin/webmin/webmin-1.760.ebuild)7
3 files changed, 22 insertions, 5 deletions
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 8832186a3e8f..b6a050595a66 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,2 +1,2 @@
-DIST webmin-1.760-minimal.tar.gz 2601515 SHA256 1a9faf4d765f7356a2db39bee22f7030daa95be1f2f06d1de40a9dbbeecc4d9c SHA512 c6e1b5fae3921a368b9341d21285e0b3c2366331250849846d1ebb221958b809bce83d96f0506972cc9b2f474fd4059ecb935b80b6593d09a65947cdc47950d4 WHIRLPOOL d4c0c1215419b700fad742904fdd55918955bfe0447d8b7c2278303abbd54d20e4bd22af726ed6645639ef81dcaef2c4ccd8aa7f3f1bafccbee8f36022da3ff5
-DIST webmin-1.760.tar.gz 26885420 SHA256 6e7adefe2a8349487484a15b94914ab7e540404b43f97dc49b21a618c9b1776e SHA512 8d7ce0b88dd561e91ba36dc97d4f0ab6da616726cefd6b53d642641eb82a906bddd9f0a5b8b5e3875336ac9f6a70bda9595e74d062952d653e72dae226db6e8f WHIRLPOOL b1fc7e4719b384ee5f1b3c6e023bc9d5790b0e30320c726942bcd5b72c4afbaf380526dfee05eb515a5a3280fea35143f5ed2be50621c7e7977dc01f91700a7e
+DIST webmin-1.770-minimal.tar.gz 2612198 SHA256 e976091dcf0a68dfb02d5633d09da2ce9dc69d8ea2bde95c3cc57a0a25384488 SHA512 3661e37bbeb9f814862ff208d32ec4bfa15e8e826c15833e47c3a39cb0bb47d1f227c0c942f72aed4f3e9344556cc0ef8de42a5961c6795ef01986abafe9949b WHIRLPOOL 92a89623da8ba09d921ffec38c45c2c4bf04c8249178d9d13d34339ecc902d8d7184396ce29c04bfb6e9eba463c2942dc5d9d10d05af463b4dbf9337891bcc02
+DIST webmin-1.770.tar.gz 28441983 SHA256 eb84f1adbb099d0a2e633fbc4ea4838d1ddbcc84135d6a897803fbd0284719ba SHA512 460d9e06379df8d950874906589938077fd0fc70ed12948a685c1386c9995538d92387e252373398319469406b8ef0daab67dabe8c71b2f1961a5d5cb6848a7f WHIRLPOOL 4556f51001d010b66c6af265904b3f634f7bccf1afeb74be6de0824fefb2a5b2a5508d751bfa4abcfd0cb8b670659474ecf4e564505e446ed36a737e4f100dc0
diff --git a/app-admin/webmin/files/gentoo-setup b/app-admin/webmin/files/gentoo-setup
index 0c2dd2d186d1..47d6127a56cf 100644
--- a/app-admin/webmin/files/gentoo-setup
+++ b/app-admin/webmin/files/gentoo-setup
@@ -94,13 +94,15 @@ if [ "$upgrading" = 1 ]; then
real_os_type=`grep "^real_os_type=" $config_dir/config | sed -e 's/real_os_type=//g'`
real_os_version=`grep "^real_os_version=" $config_dir/config | sed -e 's/real_os_version=//g'`
- # Get port, ssl, no_ssl2, no_ssl3, ssl_redirect, no_sslcompression and keyfile
+ # Get port, ssl, no_ssl2, no_ssl3, ssl_redirect, no_sslcompression, no_tls1, no_tls1_1 and keyfile
port=`grep "^port=" $config_dir/miniserv.conf | sed -e 's/port=//g'`
ssl=`grep "^ssl=" $config_dir/miniserv.conf | sed -e 's/ssl=//g'`
no_ssl2=`grep "^no_ssl2=" $config_dir/miniserv.conf | sed -e 's/no_ssl2=//g'`
no_ssl3=`grep "^no_ssl3=" $config_dir/miniserv.conf | sed -e 's/no_ssl3=//g'`
ssl_redirect=`grep "^ssl_redirect=" $config_dir/miniserv.conf | sed -e 's/ssl_redirect=//g'`
no_sslcompression=`grep "^no_sslcompression=" $config_dir/miniserv.conf | sed -e 's/no_sslcompression=//g'`
+ no_tls1=`grep "^no_tls1=" $config_dir/miniserv.conf | sed -e 's/no_tls1=//g'`
+ no_tls1_1=`grep "^no_tls1_1=" $config_dir/miniserv.conf | sed -e 's/no_tls1_1=//g'`
keyfile=`grep "^keyfile=" $config_dir/miniserv.conf | sed -e 's/keyfile=//g'`
# Update ACLs
@@ -145,6 +147,8 @@ else
echo "no_ssl3=$no_ssl3" >> $cfile
echo "ssl_redirect=$ssl_redirect" >> $cfile
echo "no_sslcompression=$no_sslcompression" >> $cfile
+ echo "no_tls1=$no_tls1" >> $cfile
+ echo "no_tls1_1=$no_tls1_1" >> $cfile
echo "keyfile=$keyfile" >> $cfile
echo "env_WEBMIN_CONFIG=$config_dir" >> $cfile
echo "env_WEBMIN_VAR=$var_dir" >> $cfile
@@ -320,6 +324,16 @@ if [ "$?" != "0" ]; then
echo no_ssl3=1 >> $config_dir/miniserv.conf
fi
+grep no_tls1= $config_dir/miniserv.conf >/dev/null
+if [ "$?" != "0" ]; then
+ echo no_tls1=1 >> $config_dir/miniserv.conf
+fi
+
+grep no_tls1_1= $config_dir/miniserv.conf >/dev/null
+if [ "$?" != "0" ]; then
+ echo no_tls1_1=1 >> $config_dir/miniserv.conf
+fi
+
# Make Perl crypt MD5 the default
grep md5pass= $config_dir/config >/dev/null
if [ "$?" != "0" ]; then
diff --git a/app-admin/webmin/webmin-1.760.ebuild b/app-admin/webmin/webmin-1.770.ebuild
index 54f23b10a374..eb7f7a9fb001 100644
--- a/app-admin/webmin/webmin-1.760.ebuild
+++ b/app-admin/webmin/webmin-1.770.ebuild
@@ -129,7 +129,7 @@ src_install() {
-e "s:%conf%:${EROOT}etc/webmin/miniserv.conf:" \
-e "s:%config%:${EROOT}etc/webmin/config:" \
-e "s:%perllib%:${EROOT}usr/libexec/webmin:" \
- "${ED}$(_systemd_get_unitdir)/webmin.service" \
+ "${ED}$(_systemd_get_systemunitdir)/webmin.service" \
|| die "Failed to patch the webmin systemd service file"
# Setup pam
@@ -286,12 +286,15 @@ pkg_config(){
export os_version='*'
export real_os_type='Gentoo Linux'
export real_os_version='Any version'
- # Forcing 'ssl', 'no_ssl2', 'no_ssl3', 'ssl_redirect' and 'no_sslcompression' for tightening security
+ # Forcing 'ssl', 'no_ssl2', 'no_ssl3', 'ssl_redirect', 'no_sslcompression',
+ # 'no_tls1' and 'no_tls1_1' for tightening security
export ssl=1
export no_ssl2=1
export no_ssl3=1
export ssl_redirect=1
export no_sslcompression=1
+ export no_tls1=1
+ export no_tls1_1=1
export keyfile="${EROOT}etc/ssl/webmin/server.pem"
export port=10000